4 Replies Latest reply on Jul 20, 2020 8:07 PM by g0dMAn

    Horizon 7.5.0 - Clipboard Redirection Stops

    g0dMAn Novice

      Horizon 7.5.0, with UAG, using pcoip, ADMX templates injected for GPO to enable bidirectional clipboard.  Windows 10 VM.

       

      I've been working remotely due to covid and using VDI full-time.

      It works great, but then after several days, the bidrectional clipboard becomes nondirectional (doesn't work in either direction).  The clipboard works locally on my local desktop and within VDI, but not through the pcoip session.

       

      I've tried connecting to my VM from another desktop, but it doesn't help.  The only solution is to restart the VM.  I've tried disconnecting session and reconnecting, gpupdate /force, restarting the horizon agent on the VM (which boots me off so then i reconnect), and other versions of the Horizon client.  Nothing fixes it, but a VM reboot.

       

      I even looked in the registry and see the flag set appropriately.  I think I've even uninstalled and reinstalled the Horizon agent.

       

      Any ideas?

       

      When I look at gpresult, I see "Configure clipboard redirection" set to enabled in both directions and the winning GPO is there.  I also see, under Extra Registry Settings, "software\policies\teradici\pcoip_admin\pcoip.server_clipboard_state" flag set to 1 via the winning GPO.

       

      Again, it works, but after several days it completely stops working and requires a VM reboot.