8 Replies Latest reply on Jun 30, 2020 3:04 PM by biovil

    Vmware esxi 6.7 u3 VM console blank grey screen!

    biovil Lurker

      I just upgraded a  new installation of Vmware esxi 6.5 to 6.7 u3. Created a vm with Windows 10 iso, installed the OS and initiated Vmware tools installed. Everything worked just fine and it is running smoothly.

      Then cloned it to a new vm, an exact clone, but the vm console is showing a blank grey screen!

       

      Then I moved a Windows 7 vm from another server with Vmware esx6 and powered it, the console works just fine. Made a clone of it and again the same, nothing in the console! Screenshot is attached. You can see the small preview of the console is showing the OS login screen but the console itself shows nothing!

      For any moved VM console is working, also it works for any vm created on itself, but not working for any cloned vm!

        • 1. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
          AlessandroRomeo68 Master

          Hi,

           

          What version do you have for Windows 7? Also try reinstalling the vmware tools on a computer that has the problem.

           

          a similar problem happened to me and reinstalling the latest version of VMRC resumed normal operation:

          https://my.vmware.com/en/web/vmware/downloads/details?downloadGroup=VMRC1110&productId=974

           

          ARomeo

          • 2. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
            biovil Lurker

            But I suppose this has nothing to do with the client side, here is the screenshot:

            https://puu.sh/G2fbq/2bb0e6a2fa.png

             

            Left is the clone and right is the actual vm. The problem is cloned one does not show the console contents.

            • 3. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
              AlessandroRomeo68 Master

              Hi,

               

              I understand what you are saying, but did you upgrade to Esxi 6.7U3. what version do you have on the vmware tools vm and what version are you using of VMRC?

               

              ARomeo

              • 4. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
                biovil Lurker

                Yes, it is 6.7u3.

                The working one has version 11269 but the cloned one shows vmware tools 11.0.5 build 15389592.

                • 5. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
                  AlessandroRomeo68 Master

                  ...has version 11269 ?????

                   

                  When performing an Esxi version upgrade, vmware tools must be updated on all virtual machines. This is to make VMs work better.

                  Virtual hardware must also be changed:

                  VMware Knowledge Base

                   

                  ARomeo

                  • 6. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
                    biovil Lurker

                    Ok now both shows vmware tools 11.0.5 build 15389592.

                    virtualhw version on the working one is 11 amd the none-working one is 14:

                     

                    vmx file contents for the working one:

                     

                    .encoding = "UTF-8"

                    config.version = "8"

                    virtualHW.version = "11"

                    nvram = "win7_32bit.nvram"

                    pciBridge0.present = "TRUE"

                    svga.present = "TRUE"

                    pciBridge4.present = "TRUE"

                    pciBridge4.virtualDev = "pcieRootPort"

                    pciBridge4.functions = "8"

                    pciBridge5.present = "TRUE"

                    pciBridge5.virtualDev = "pcieRootPort"

                    pciBridge5.functions = "8"

                    pciBridge6.present = "TRUE"

                    pciBridge6.virtualDev = "pcieRootPort"

                    pciBridge6.functions = "8"

                    pciBridge7.present = "TRUE"

                    pciBridge7.virtualDev = "pcieRootPort"

                    pciBridge7.functions = "8"

                    vmci0.present = "TRUE"

                    hpet0.present = "TRUE"

                    floppy0.present = "FALSE"

                    svga.vramSize = "8388608"

                    memSize = "1024"

                    tools.upgrade.policy = "manual"

                    vm.createDate = "1593507862655249"

                    scsi0.virtualDev = "lsisas1068"

                    scsi0.pciSlotNumber = "160"

                    scsi0.present = "TRUE"

                    ide1:0.startConnected = "FALSE"

                    ide1:0.deviceType = "atapi-cdrom"

                    ide1:0.clientDevice = "TRUE"

                    ide1:0.fileName = "CD/DVD drive 0"

                    ide1:0.present = "TRUE"

                    scsi0:0.deviceType = "scsi-hardDisk"

                    scsi0:0.fileName = "win7_32bit.vmdk"

                    scsi0:0.present = "TRUE"

                    vmci0.pciSlotNumber = "33"

                    ethernet0.virtualDev = "e1000"

                    ethernet0.networkName = "VM Network"

                    ethernet0.addressType = "generated"

                    ethernet0.pciSlotNumber = "32"

                    ethernet0.present = "TRUE"

                    displayName = "win7_32bit"

                    annotation = "Windows 7 (32)"

                    guestOS = "windows7"

                    toolScripts.afterPowerOn = "TRUE"

                    toolScripts.afterResume = "TRUE"

                    toolScripts.beforeSuspend = "TRUE"

                    toolScripts.beforePowerOff = "TRUE"

                    tools.syncTime = "FALSE"

                    uuid.bios = "56 4d 09 ce d3 18 a8 90-cc 30 d6 a3 d7 b7 28 e9"

                    uuid.location = "56 4d 09 ce d3 18 a8 90-cc 30 d6 a3 d7 b7 28 e9"

                    vc.uuid = "52 63 0f f7 ea 28 e7 69-6a a3 1b 32 6f 63 fc 6a"

                    numa.autosize.cookie = "10001"

                    numa.autosize.vcpu.maxPerVirtualNode = "1"

                    sched.swap.derivedName = "/vmfs/volumes/5efa1c9e-c731ca42-87e0-002590f427ea/win7_32bit/win7_32bit-72badd0f.vswp"

                    migrate.hostlog = "./win7_32bit-72badd0f.hlog"

                    scsi0:0.redo = ""

                    pciBridge0.pciSlotNumber = "17"

                    pciBridge4.pciSlotNumber = "21"

                    pciBridge5.pciSlotNumber = "22"

                    pciBridge6.pciSlotNumber = "23"

                    pciBridge7.pciSlotNumber = "24"

                    scsi0.sasWWID = "50 05 05 6e d3 18 a8 90"

                    ethernet0.generatedAddress = "00:0c:29:b7:28:e9"

                    ethernet0.generatedAddressOffset = "0"

                    vmci0.id = "-675862295"

                    monitor.phys_bits_used = "42"

                    vmotion.checkpointFBSize = "8388608"

                    vmotion.checkpointSVGAPrimarySize = "8388608"

                    cleanShutdown = "TRUE"

                    softPowerOff = "TRUE"

                    svga.guestBackedPrimaryAware = "TRUE"

                    extendedConfigFile = "win7_32bit.vmxf"

                    toolsInstallManager.updateCounter = "2"

                    tools.remindInstall = "FALSE"

                    toolsInstallManager.lastInstallError = "0"

                    guestOS.detailed.data = ""

                     

                     

                     

                    For the none working one:

                    .encoding = "UTF-8"

                    config.version = "8"

                    nvram = "autovm.nvram"

                    pciBridge0.present = "TRUE"

                    svga.present = "TRUE"

                    pciBridge4.present = "TRUE"

                    pciBridge4.virtualDev = "pcieRootPort"

                    pciBridge4.functions = "8"

                    pciBridge5.present = "TRUE"

                    pciBridge5.virtualDev = "pcieRootPort"

                    pciBridge5.functions = "8"

                    pciBridge6.present = "TRUE"

                    pciBridge6.virtualDev = "pcieRootPort"

                    pciBridge6.functions = "8"

                    pciBridge7.present = "TRUE"

                    pciBridge7.virtualDev = "pcieRootPort"

                    pciBridge7.functions = "8"

                    vmci0.present = "TRUE"

                    hpet0.present = "TRUE"

                    sched.cpu.units = "mhz"

                    powerType.powerOff = "soft"

                    powerType.suspend = "hard"

                    powerType.reset = "soft"

                    ide1:0.deviceType = "cdrom-image"

                    ide1:0.fileName = "emptyBackingString"

                    ide1:0.present = "TRUE"

                    floppy0.startConnected = "FALSE"

                    floppy0.clientDevice = "TRUE"

                    floppy0.fileName = "vmware-null-remote-floppy"

                    ethernet0.present = "TRUE"

                    disk.EnableUUID = "TRUE"

                    toolScripts.afterPowerOn = "TRUE"

                    toolScripts.afterResume = "TRUE"

                    toolScripts.beforeSuspend = "TRUE"

                    toolScripts.beforePowerOff = "TRUE"

                    chipset.onlineStandby = "FALSE"

                    sched.cpu.min = "0"

                    sched.cpu.shares = "normal"

                    sched.mem.min = "0"

                    sched.mem.minSize = "0"

                    sched.mem.shares = "normal"

                    toolsInstallManager.lastInstallError = "0"

                    tools.syncTime = "FALSE"

                    toolsInstallManager.updateCounter = "1"

                    tools.remindInstall = "FALSE"

                    scsi0.present = "TRUE"

                    scsi0:0.present = "TRUE"

                    scsi0:0.fileName = "template.vmdk"

                    RemoteDisplay.vnc.password = "ulqvgomfh"

                    virtualHw.version = "14"

                    displayName = "xxxxxxxx"

                    sched.cpu.max = "1800"

                    memSize = "2048"

                    sched.mem.max = "2048"

                    numvcpus = "1"

                    RemoteDisplay.vnc.enabled = "TRUE"

                    ethernet0.virtualDev = "vmxnet3"

                    RemoteDisplay.vnc.port = "9510"

                    ethernet0.networkName = "VM Network"

                    guestOs = "windows7"

                    ethernet0.addressType = "generated"

                    scsi0.virtualDev = "lsisas1068"

                    RemoteDisplay.vnc.key = "Hiw7Gxc7NSEPLxQeHzMxHw8NNzEnPz8YNx0KPScqFz43Oz4PHyoiOR8bAz4bPz8jFR8ZLys9HBw1My4RLi0+JTcXHx06HSEuMTM0NjkfFz05Og8bPD8fGj4uEg0+HS89OicnPjcVMjArNyovNTY9Di8sHCUdPh4zOj0/HB8yDyY="

                    numa.autosize.cookie = "10001"

                    numa.autosize.vcpu.maxPerVirtualNode = "1"

                    sched.swap.derivedName = "/vmfs/volumes/5efa1c9e-c731ca42-87e0-002590f427ea/173.243.112.253/template-3cf97b13.vswp"

                    uuid.bios = "56 4d c3 ad ac 0c 1c 7e-e3 e6 12 06 cb 27 33 67"

                    uuid.location = "56 4d c3 ad ac 0c 1c 7e-e3 e6 12 06 cb 27 33 67"

                    migrate.hostlog = "./template-3cf97b13.hlog"

                    scsi0:0.redo = ""

                    pciBridge0.pciSlotNumber = "17"

                    pciBridge4.pciSlotNumber = "21"

                    pciBridge5.pciSlotNumber = "22"

                    pciBridge6.pciSlotNumber = "23"

                    pciBridge7.pciSlotNumber = "24"

                    scsi0.pciSlotNumber = "160"

                    ethernet0.pciSlotNumber = "192"

                    vmci0.pciSlotNumber = "32"

                    scsi0.sasWWID = "50 05 05 6d ac 0c 1c 70"

                    ethernet0.generatedAddress = "00:0c:29:27:33:67"

                    ethernet0.generatedAddressOffset = "0"

                    vmci0.id = "-886623385"

                    svga.vramSize = "8388608"

                    monitor.phys_bits_used = "43"

                    vmotion.checkpointFBSize = "8388608"

                    vmotion.checkpointSVGAPrimarySize = "8388608"

                    cleanShutdown = "FALSE"

                    softPowerOff = "FALSE"

                    svga.guestBackedPrimaryAware = "TRUE"

                    extendedConfigFile = "template.vmxf"

                    guestOS.detailed.data = ""

                    • 7. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
                      biovil Lurker

                      I tried the cloned with virtualhw 11 too, no success. The problem is I dont see any log or error to start the investigation from!

                       

                      .encoding = "UTF-8"

                      config.version = "8"

                      nvram = "autovm.nvram"

                      pciBridge0.present = "TRUE"

                      svga.present = "TRUE"

                      pciBridge4.present = "TRUE"

                      pciBridge4.virtualDev = "pcieRootPort"

                      pciBridge4.functions = "8"

                      pciBridge5.present = "TRUE"

                      pciBridge5.virtualDev = "pcieRootPort"

                      pciBridge5.functions = "8"

                      pciBridge6.present = "TRUE"

                      pciBridge6.virtualDev = "pcieRootPort"

                      pciBridge6.functions = "8"

                      pciBridge7.present = "TRUE"

                      pciBridge7.virtualDev = "pcieRootPort"

                      pciBridge7.functions = "8"

                      vmci0.present = "TRUE"

                      hpet0.present = "TRUE"

                      sched.cpu.units = "mhz"

                      powerType.powerOff = "soft"

                      powerType.suspend = "hard"

                      powerType.reset = "soft"

                      ide1:0.deviceType = "cdrom-image"

                      ide1:0.fileName = "emptyBackingString"

                      ide1:0.present = "TRUE"

                      floppy0.startConnected = "FALSE"

                      floppy0.clientDevice = "TRUE"

                      floppy0.fileName = "vmware-null-remote-floppy"

                      ethernet0.present = "TRUE"

                      disk.EnableUUID = "TRUE"

                      toolScripts.afterPowerOn = "TRUE"

                      toolScripts.afterResume = "TRUE"

                      toolScripts.beforeSuspend = "TRUE"

                      toolScripts.beforePowerOff = "TRUE"

                      chipset.onlineStandby = "FALSE"

                      sched.cpu.min = "0"

                      sched.cpu.shares = "normal"

                      sched.mem.min = "0"

                      sched.mem.minSize = "0"

                      sched.mem.shares = "normal"

                      toolsInstallManager.lastInstallError = "0"

                      tools.syncTime = "FALSE"

                      toolsInstallManager.updateCounter = "1"

                      tools.remindInstall = "FALSE"

                      scsi0.present = "TRUE"

                      scsi0:0.present = "TRUE"

                      scsi0:0.fileName = "template.vmdk"

                      RemoteDisplay.vnc.password = "yqrqsllfb"

                      virtualHw.version = "11"

                      displayName = "xxxxxxxx"

                      sched.cpu.max = "1800"

                      memSize = "2048"

                      sched.mem.max = "2048"

                      numvcpus = "1"

                      RemoteDisplay.vnc.enabled = "TRUE"

                      ethernet0.virtualDev = "vmxnet3"

                      RemoteDisplay.vnc.port = "9165"

                      ethernet0.networkName = "VM Network"

                      guestOs = "windows7"

                      ethernet0.addressType = "generated"

                      scsi0.virtualDev = "lsisas1068"

                      RemoteDisplay.vnc.key = "Hi8HGB87MiQeLwgVPzMxLS8fJSMnNwI5Jx0LCj8uDyY3ORQOHzsIFR87JxA7OzkAPR8gJS89FR43Fz4BPi0CMjc3DBg+Dw0iOzswAjkfJRk5PiMwOz86EjwvGi0+PSAOPyc8NDYXAiErPwkaNR4VCzs8EQEfPg4dPjwfMR87GAA="

                      numa.autosize.cookie = "10001"

                      numa.autosize.vcpu.maxPerVirtualNode = "1"

                      sched.swap.derivedName = "/vmfs/volumes/5efa1c9e-c731ca42-87e0-002590f427ea/173.243.112.253/template-3cf97b13.vswp"

                      uuid.bios = "56 4d c3 ad ac 0c 1c 7e-e3 e6 12 06 cb 27 33 67"

                      uuid.location = "56 4d c3 ad ac 0c 1c 7e-e3 e6 12 06 cb 27 33 67"

                      migrate.hostlog = "./template-3cf97b13.hlog"

                      scsi0:0.redo = ""

                      pciBridge0.pciSlotNumber = "17"

                      pciBridge4.pciSlotNumber = "21"

                      pciBridge5.pciSlotNumber = "22"

                      pciBridge6.pciSlotNumber = "23"

                      pciBridge7.pciSlotNumber = "24"

                      scsi0.pciSlotNumber = "160"

                      ethernet0.pciSlotNumber = "192"

                      vmci0.pciSlotNumber = "32"

                      scsi0.sasWWID = "50 05 05 6d ac 0c 1c 70"

                      ethernet0.generatedAddress = "00:0c:29:27:33:67"

                      ethernet0.generatedAddressOffset = "0"

                      vmci0.id = "-886623385"

                      svga.vramSize = "8388608"

                      monitor.phys_bits_used = "42"

                      vmotion.checkpointFBSize = "8388608"

                      vmotion.checkpointSVGAPrimarySize = "8388608"

                      cleanShutdown = "FALSE"

                      softPowerOff = "FALSE"

                      • 8. Re: Vmware esxi 6.7 u3 VM console blank grey screen!
                        biovil Lurker

                        I wonder whats the difference between these two parts that one is showing and the other not?

                        chrome_qK3FHK5DMw.png