1 Reply Latest reply on Jun 26, 2020 6:14 AM by VirtualSpence

    App Volumes 4.0 on Server 2016 RDSH not attaching

    jmapt Novice

      Fresh install of App Volumes 4.0 and built an application and package and packaged it on a 2016 Server with the RDSH role on it.  The issue I am seeing is when I assign the App Volume to a user and that user logs into the RDSH in question.  The App Volume never attaches and it doesn't show in the local agent log on the RDSH.  On the App Volume Manager, I do see the following line:

       

      Culling assigned AppStacks for "User <DOMAIN\user>" because "Computer <DOMAIN\Server1$>" is a terminal server

       

      It appears that it thinks because this is a terminal server, that it won't mount any App Volume.  I have also tried assigning this to the OU the server is in as well as the server itself.  Same result.

       

      I did also see this KB (VMware Knowledge Base ) and it seems to reference version 4.x so it seems like it should work, but still can't get it to.

       

      Any ideas on what I am missing here or how to get an App Volume to attach in an RDSH session?

        • 1. Re: App Volumes 4.0 on Server 2016 RDSH not attaching
          VirtualSpence Enthusiast
          VMware Employees

          When using App Volumes with application publishing, the package must be attached to the RDS host at startup. This makes the program(s) contained in the package available to users who access the RDS host. Because of this, only assignments to the computer object (direct or using the OU where computers objects reside) are supported with RDSH.

           

          After you assign the package to the machine object, the RDS host must be rebooted so the package can be attached at startup. Have you tried rebooting the RDS host(s) after assigning to the OU?

           

          If you're still having trouble, please post manager and agent log snippet when the error occurs.

          1 person found this helpful