1 Reply Latest reply on Jun 26, 2020 10:57 AM by ahteraydin

    VCSA 6.0 U2 -> 6.7 U3 Upgrade fails at pre-upgrade check on stage 2

    ahteraydin Lurker

      Hi,

      I am trying to upgrade my VCSA 6.0 Update 2 (3634794) to VCSA 6.7 Update 3h (16275304). I also tried to upgrade to VCSA 6.5 but received the same errors. I run an external VUM on a Windows machine, the migration assistant is also running in the background.

      The upgrade process always fails at the pre-upgrade check on stage 2. I checked many topics/discussions, all my log files but still I couldn't figure out what is causing the error(s).

      I am getting the error "Cannot validate target appliance configuration as not enough information from the source appliance can be collected. For more details check out the server logs".

      When I check my log files I can see only the error and warnings below (I also attached all the log files):

      cloudvm.log

      net.ipv4.ip_local_reserved_ports = 902

         Enable performance logs

      Note: Forwarding request to 'systemctl enable sysstat.service'.

      Failed to execute operation: No such file or directory

         Executing the runonce scripts

         Blacklisting vpxd hartbeat port from the ones rpcbind uses

         Configure ssh

      /usr/sbin/usermod.bk -a -G shellaccess root

      Add system logging to /sbin/ifup

         Setting global java options

         Fixing likewise configuration

      SUCCESS

      SUCCESS

         Patch slow vami cd mounting

      patching file vami_ovf_process

      Hunk #1 succeeded at 308 with fuzz 1 (offset 59 lines).

      Setting up subsequent boot script

      2020-06-25T14:32:30.357Z: Upating deployment node type embedded

      2020-06-25T14:33:00.665Z: Upgrade CHECKS requested. Starting...

      2020-06-25T14:34:36.425Z: Upgrade CHECKS failed.

      2020-06-25T14:34:36.427Z: Starting ssh...

      2020-06-25T14:34:36.482Z: No support bundle for precheck

      2020-06-25T14:54:26.440Z: Upgrade CHECKS requested. Starting...

      2020-06-25T14:56:03.224Z: Upgrade CHECKS failed.

      2020-06-25T14:56:03.228Z: Starting ssh...

      2020-06-25T14:56:03.276Z: No support bundle for precheck

      2020-06-25T15:23:07.857Z: Upgrade CHECKS requested. Starting...

      2020-06-25T15:24:49.752Z: Upgrade CHECKS failed.

      2020-06-25T15:24:49.756Z: Starting ssh...

      2020-06-25T15:24:49.804Z: No support bundle for precheck

       

      bootstrap.log

      2020-06-25T15:24:44.968Z ERROR upgrade_commands Unable to execute pre-upgrade checks on target machine

      Traceback (most recent call last):

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/upgrade_commands.py", line 2755, in _executeTargetPreupgradeChecks

          if self._validateNetworking(preupgradeResult):

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/upgrade_commands.py", line 2602, in _validateNetworking

          sourceConfig = self._retrieveSourceNetworkConfiguration()

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/upgrade_commands.py", line 3285, in _retrieveSourceNetworkConfiguration

          timesyncConfig = retrieveTimeSyncConfiguration(self.opsManager)

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/transfer_network.py", line 116, in retrieveTimeSyncConfiguration

          ntpstatus = transport.getCommandOutput(processManager, chkconfigCmd).strip().split()[-1]

      IndexError: list index out of range

      2020-06-25T14:33:36.998Z ERROR transport.guestops Invalid command: "/bin/bash" --login -c 'python3 -c "import sys;sys.stdout.write(sys.executable)" 1>/tmp/vmware-root/exec-vmware889-stdout 2>/tmp/vmware-root/exec-vmware661-stderr'

      NoneType: None

      2020-06-25T14:33:36.999Z WARNING os_utils Error while looking for python path, assume None

       

      upgrade-requirements.log

      2020-06-25T15:23:43.419Z ERROR transport.guestops Invalid command: "/bin/bash" --login -c 'python3 -c "import sys;sys.stdout.write(sys.executable)" 1>/tmp/vmware-root/exec-vmware165-stdout 2>/tmp/vmware-root/exec-vmware53-stderr'

      NoneType: None

      2020-06-25T15:23:43.420Z WARNING os_utils Error while looking for python path, assume None

      2020-06-25T15:24:44.968Z ERROR upgrade_commands Unable to execute pre-upgrade checks on target machine

      Traceback (most recent call last):

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/upgrade_commands.py", line 2755, in _executeTargetPreupgradeChecks

          if self._validateNetworking(preupgradeResult):

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/upgrade_commands.py", line 2602, in _validateNetworking

          sourceConfig = self._retrieveSourceNetworkConfiguration()

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/upgrade_commands.py", line 3285, in _retrieveSourceNetworkConfiguration

          timesyncConfig = retrieveTimeSyncConfiguration(self.opsManager)

        File "/usr/lib/vmware/cis_upgrade_runner/bootstrap_scripts/transfer_network.py", line 116, in retrieveTimeSyncConfiguration

          ntpstatus = transport.getCommandOutput(processManager, chkconfigCmd).strip().split()[-1]

      IndexError: list index out of range

       

      upgrade-source-requirements.log

      2020-06-25T15:24:31.209Z INFO sso_connector SSO https port is configured to: 443

      2020-06-25T15:24:31.229Z ERROR bindings.sso_binding Cannot log-in to SSO admin service, because of Error: (vmodl.fault.InvalidRequest) {

         dynamicType = <unset>,

         dynamicProperty = (vmodl.DynamicProperty) [],

         msg = "Request version 'urn:sso/version3_5' and namespace 'urn:sso' are not supported",

         faultCause = <unset>,

         faultMessage = (vmodl.LocalizableMessage) []

      }.

      Traceback (most recent call last):

        File "/tmp/vmware-upgrade-temp-dir0oky7CoZEP/tmpRdNr7qWwhW/py/bindings/sso_binding.py", line 138, in createSession

          content = si.RetrieveServiceContent()

        File "/tmp/vmware-upgrade-temp-dir0oky7CoZEP/tmpRdNr7qWwhW/libs/pyVmomi.zip/pyVmomi/VmomiSupport.py", line 557, in <lambda>

          self.f(*(self.args + (obj,) + args), **kwargs)

        File "/tmp/vmware-upgrade-temp-dir0oky7CoZEP/tmpRdNr7qWwhW/libs/pyVmomi.zip/pyVmomi/VmomiSupport.py", line 363, in _InvokeMethod

          return self._stub.InvokeMethod(self, info, args)

        File "/tmp/vmware-upgrade-temp-dir0oky7CoZEP/tmpRdNr7qWwhW/libs/pyVmomi.zip/pyVmomi/SoapAdapter.py", line 1418, in InvokeMethod

          raise obj # pylint: disable-msg=E0702

      vmodl.fault.InvalidRequest: (vmodl.fault.InvalidRequest) {

         dynamicType = <unset>,

         dynamicProperty = (vmodl.DynamicProperty) [],

         msg = "Request version 'urn:sso/version3_5' and namespace 'urn:sso' are not supported",

         faultCause = <unset>,

         faultMessage = (vmodl.LocalizableMessage) []

      }

      2020-06-25T15:24:31.231Z WARNING bindings.sso_binding Could not retrieve service instance from SSO component using API version 'sso.version.version3_5'. Falling back to API version 'sso.version.version1'.

      2020-06-25T15:24:31.276Z INFO bindings.sso_binding SSO API version is '3.2'

      2020-06-25T15:24:31.276Z INFO bindings.sso_binding SSO translated product version is '6.0'

      2020-06-25T15:24:31.284Z INFO common /bin/df command completed with exit code 0

      2020-06-25T15:24:31.285Z INFO sso_connector Executing command: ['/usr/lib/vmware-vmafd/bin/vmafd-cli', 'get-domain-name', '--server-name', 'localhost']

      2020-06-25T15:24:31.293Z INFO sso_connector SSO domain-name is configured to: vsphere.local

      2020-06-25T15:24:31.293Z INFO vc_connector Parse rhttpproxy config file /etc/vmware-rhttpproxy/config.xml

      2020-06-25T15:24:31.294Z INFO vc_connector Proxy http port is configured to: 80

      2020-06-25T15:24:31.294Z INFO vc_connector Proxy https port is configured to: 443

      2020-06-25T15:24:31.485Z INFO apply_networking Checking network adapter eth0

      2020-06-25T15:24:31.485Z INFO apply_networking Extracting active network adapters on host localhost

      2020-06-25T15:24:31.489Z INFO apply_networking Active Network adapters  found are ['eth0']

      2020-06-25T15:24:31.489Z INFO apply_networking Network adapter eth0 present in ['eth0']: True

      2020-06-25T15:24:31.557Z INFO __main__ SUCCESS: All upgrade requirements are fulfilled.

      2020-06-25T15:24:31.565Z INFO root Exiting with exit-code 0

       

       

      Hope someone can help me out here.

      Thanks