6 Replies Latest reply on Jun 30, 2020 10:45 PM by randybias_new

    VMWare Fusion Could not open /dev/vmmon: Broken pipe

    Ken_H Novice

      I'm not sure what happened.  VMWare Fusion was working after I upgraded to macOS Mojave and then some time later stopped working.  I'm getting:

      > Could not open /dev/vmmon: Broken pipe

      > Please make sure that the kernel module 'vmmon' is loaded

      followed by:

      > Failed to initialize monitor device

      followed by:

      > Transport (VMDB) error -14: Pip connection has been broken

       

      I uninstalled VMWare Fusion including the manual cleanup as documented in https://kb.vmware.com/s/article/1017838.

      , emptied the trash, rebooted, re-downloaded the installee, reinstalled, and I still get the same errors.  I still get the error and, oddly, even after doing all all the uninstall and cleanup, Fusion still knows my license key. 

       

      Any suggestions on where the problem is?

       

      Ken

        • 1. Re: VMWare Fusion Could not open /dev/vmmon: Broken pipe
          Ken_H Novice

          I must have missed something the first time as I did the uninstall and cleanup again, rebooted, ran the Fusion installer and was prompted for a license key.  So far so good.  I'm at the "Select the Installation Method" screen and there's an option to "Import an existing virtual machine" but for some odd reason, It won't let me use my previous VMware file.  The option for "Install from disk or image" is to create a new virtual machine but I don't want that.  Ugh, this is so frustrating.

          • 2. Re: VMWare Fusion Could not open /dev/vmmon: Broken pipe
            Ken_H Novice

            Closing and restarting Fusion allows me to open my original virtual computer file but I still get the "Could not open /dev/vmmon: Broken Pipe" errors so it appears the uninstalling and reinstalling has no effect.  In addition, I've checked System Preferences > Privacy to see if there's a prompt to allow access to VMWare but there is none. 

            • 3. Re: VMWare Fusion Could not open /dev/vmmon: Broken pipe
              Ken_H Novice

              I upgraded to macOS Catalina and now Fusion is working.  The bad news is that my Microsoft Office is now dead.  The previous post for this problem was over 2 years old and it's frustrating that VMWare hasn't figured out a process for tracing through and fixing this problem without having to essentially reinstall both macOS and Fusion.

              • 4. Re: VMWare Fusion Could not open /dev/vmmon: Broken pipe
                RemekDantha Novice

                I have the same problem with VMware Fusion 11.5.5 and MacOS 10.14.6. There are a couple unsatisfactory ways around it:

                 

                • "csrutil disable" from Recovery mode works to fix this, but the problem reappears if I do "csrutil enable" and I don't want to keep my Mac with SIP disabled.
                • Fully reinstalling MacOS 10.14.6 from Recovery also fixed this. However, that put me one minor MacOS security update out of date, so naturally MacOS wanted to update itself to grab that. Installing Apple's latest minor security update to MacOS 10.14.6 made the /dev/vmmon problem reappear.
                1 person found this helpful
                • 5. Re: VMWare Fusion Could not open /dev/vmmon: Broken pipe
                  Jalapeno69 Lurker

                  RemekDantha thank you so much for posting this!!!  I did a restore of Mojave from the recovery partition (rebooted with command-R) and now my VMware Fusion is working again!!  It must be the latest security update from Apple that is causing Fusion some issues.

                   

                  Thanks again.

                  • 6. Re: VMWare Fusion Could not open /dev/vmmon: Broken pipe
                    randybias_new Lurker

                    Pretty frustrating to download and install VMware Fusion and have it immediately broken.