3 Replies Latest reply on Jun 24, 2020 12:36 PM by rpetchim

    ESX Upgrade from 67u3 to 7.0 failed

    dkumbhar Lurker
    VMware Employees

      I am getting below error:

       

      # esxcli software  profile update -d /vmfs/volumes/3da59473-8545b21e/VMware-ESXi-7.0.0-1584

      3807-depot.zip  -p ESXi-7.0.0-15843807-standard

      [HardwareError]

      Hardware precheck of profile ESXi-7.0.0-15843807-standard failed with warnings: <UNSUPPORTED_DEVICES WARNING: This host has unsupported devices [<PciInfo ' [1000:0030 15ad:1976]'>]>

       

       

      Apply --no-hardware-warning option to ignore the warnings and proceed with the transaction.

      Please refer to the log file for more details.

       

      ] esxcli software  profile update -d /vmfs/volumes/3da59473-8545b21e/VMware-ESXi-7.0.0-1584

      3807-depot.zip  -p ESXi-7.0.0-15843807-standard --no-hardware-warning

      [HardwareError]

      Hardware precheck of profile ESXi-7.0.0-15843807-standard failed with errors: <NATIVE_BOOTBANK ERROR: Found=[False] Expected=[True] Native drivers are missing for bootbank storage device.>

      Please refer to the log file for more details.

       

      esxupdate logs has below error:

      ------------------------------------------------------

      2020-06-24T08:17:32Z esxupdate: 2104379: imageprofile: INFO: Adding VIB VMware_bootbank_lsuv2-oem-dell-plugin_1.0.0-1vmw.700.1.0.15843807 to ImageProfile ESXi-7.0.0-1

      2020-06-24T08:17:32Z esxupdate: 2104379: upgrade_precheck: INFO: Running command localcli hardware pci list^@

      2020-06-24T08:17:33Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmhba0: identified native driver for device^@

      2020-06-24T08:17:33Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmnic0: identified native driver for device^@

      2020-06-24T08:17:33Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmnic0: identified native driver for device^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmnic1: identified native driver for device^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmnic1: identified native driver for device^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: INFO: Running command localcli --formatter=json storage core adapter list^@

      2020-06-24T08:17:34Z esxupdate: 2104379: vmware.runcommand: INFO: runcommand called with: args = 'localcli --formatter=json storage core adapter list', outfile = 'Non

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmhba0: identified sbdf '0000:00:07.1' for a native supported device using description '(0000:00:07.

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmhba1: rejected for native driver support non-pciiid device with sbdfAddress '0000:00:10.0' and des

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: DEBUG: vmhba64: found base native driver 'vmhba0' for non-pciiid device with sbdfAddress '0000:00:07.1'^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: DEBUG: Found native devices on the host: {'vmnic1', 'vmnic0', 'vmhba0', 'vmhba64'}^@

      2020-06-24T08:17:34Z esxupdate: 2104379: precheck: INFO: Starting precheck for localcli/esxcli, VmkLinux checks only^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: INFO: NIC uplink order of VMKernel NIC Management Network: ('vmnic0',)^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: INFO: Running command localcli --formatter=json storage core path list -d mpx.vmhba1:C0:T0:L0^@

      2020-06-24T08:17:34Z esxupdate: 2104379: vmware.runcommand: INFO: runcommand called with: args = 'localcli --formatter=json storage core path list -d mpx.vmhba1:C0:T0

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: INFO: Storage adapter for the boot disk mpx.vmhba1:C0:T0:L0: vmhba1^@

      2020-06-24T08:17:34Z esxupdate: 2104379: upgrade_precheck: ERROR: Precheck Error(s).   <NATIVE_BOOTBANK ERROR: Found=[False] Expected=[True] Native drivers are missin

      2020-06-24T08:17:35Z esxupdate: 2104379: vmware.runcommand: INFO: runcommand called with: args = 'localcli system visorfs ramdisk list | grep /esx-update-2104379 && l

      2020-06-24T08:17:35Z esxupdate: 2104379: Ramdisk: INFO: Unmounting manual tardisk /tardisks.noauto/esxupdt-2104379^@

      2020-06-24T08:17:35Z esxupdate: 2104379: Ramdisk: INFO: Unmounting manual tardisk /tardisks.noauto/tpmesxup-2104379^@

      2020-06-24T08:17:35Z esxupdate: 2104379: Ramdisk: INFO: Unmounting manual tardisk /tardisks.noauto/weaselin-2104379^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR: Traceback (most recent call last):^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 470, in <module>^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:     main()^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 461, in main^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:     ret = CMDTABLE[command](options)^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 213, in ProfileUpdateCmd^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:     nohwwarning=opts.nohwwarning)^@

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:   File "/build/mts/release/bora-14320388/bora/build/esx/release/vmvisor/esxupdate/lib64/python3.5/site-packages/

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:   File "/build/mts/release/bora-15843807/bora/build/esx/release/vmvisor/esxupdate/lib64/python3.5/site-packages/

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR:   File "/build/mts/release/bora-15843807/bora/build/esx/release/vmvisor/esxupdate/lib64/python3.5/site-packages/

      2020-06-24T08:17:35Z esxupdate: 2104379: root: ERROR: esximage.Errors.HardwareError: Hardware precheck of profile ESXi-7.0.0-15843807-standard failed with errors: <NA

      ~

       

      Note:  We were facing CPU compatibility issue before this and resolved using below link

      How to Install Nested ESXi 7.0 On Unsupported CPU (CPU_SUPPORT_ERROR)

        • 1. Re: ESX Upgrade from 67u3 to 7.0 failed
          dkumbhar Lurker
          VMware Employees

          : upgrade_precheck: INFO: Running command localcli --formatter=json storage core adapter list^@

          : vmware.runcommand: INFO: runcommand called with: args = 'localcli --formatter=json storage core adapter list', outfile = 'None', returnoutput = 'True', timeout = '0

          : upgrade_precheck: DEBUG: vmhba0: identified sbdf '0000:00:07.1' for a native supported device using description '(0000:00:07.1) Intel Corporation PIIX4 for 430TX/44

          : upgrade_precheck: DEBUG: vmhba1: rejected for native driver support non-pciiid device with sbdfAddress '0000:00:10.0' and description '(0000:00:10.0) LSI Logic / Sy

          : upgrade_precheck: DEBUG: vmhba64: found base native driver 'vmhba0' for non-pciiid device with sbdfAddress '0000:00:07.1'^@

          : upgrade_precheck: DEBUG: Found native devices on the host: {'vmnic1', 'vmnic0', 'vmhba0', 'vmhba64'}^@

          : precheck: INFO: Starting precheck for localcli/esxcli, VmkLinux checks only^@

          : upgrade_precheck: INFO: NIC uplink order of VMKernel NIC Management Network: ('vmnic0',)^@

          : upgrade_precheck: INFO: Running command localcli --formatter=json storage core path list -d mpx.vmhba1:C0:T0:L0^@

          : vmware.runcommand: INFO: runcommand called with: args = 'localcli --formatter=json storage core path list -d mpx.vmhba1:C0:T0:L0', outfile = 'None', returnoutput =

          : upgrade_precheck: INFO: Storage adapter for the boot disk mpx.vmhba1:C0:T0:L0: vmhba1^@

          : upgrade_precheck: ERROR: Precheck Error(s).   <NATIVE_BOOTBANK ERROR: Found=[False] Expected=[True] Native drivers are missing for bootbank storage device.>^@

          : vmware.runcommand: INFO: runcommand called with: args = 'localcli system visorfs ramdisk list | grep /esx-update-2104379 && localcli system visorfs ramdisk remove -

          : Ramdisk: INFO: Unmounting manual tardisk /tardisks.noauto/esxupdt-2104379^@

          : Ramdisk: INFO: Unmounting manual tardisk /tardisks.noauto/tpmesxup-2104379^@

          : Ramdisk: INFO: Unmounting manual tardisk /tardisks.noauto/weaselin-2104379^@

          : root: ERROR: Traceback (most recent call last):^@

          : root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 470, in <module>^@

          : root: ERROR:     main()^@

          : root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 461, in main^@

          : root: ERROR:     ret = CMDTABLE[command](options)^@

          : root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 213, in ProfileUpdateCmd^@

          : root: ERROR:     nohwwarning=opts.nohwwarning)^@

          : root: ERROR:   File "/build/mts/release/bora-14320388/bora/build/esx/release/vmvisor/esxupdate/lib64/python3.5/site-packages/vmware/esximage/Transaction.py", line 4

          : root: ERROR:   File "/build/mts/release/bora-15843807/bora/build/esx/release/vmvisor/esxupdate/lib64/python3.5/site-packages/vmware/esximage/Transaction.py", line 1

          : root: ERROR:   File "/build/mts/release/bora-15843807/bora/build/esx/release/vmvisor/esxupdate/lib64/python3.5/site-packages/vmware/esximage/Transaction.py", line 1

          : root: ERROR: esximage.Errors.HardwareError: Hardware precheck of profile ESXi-7.0.0-15843807-standard failed with errors: <NATIVE_BOOTBANK ERROR: Found=[False] Expe

          • 2. Re: ESX Upgrade from 67u3 to 7.0 failed
            NicolasAlauzet Hot Shot

            Did you check the compatibility of your host with the new version?

             

            Here fill your system infomatio: VMware Compatibility Guide - System Search

            • 3. Re: ESX Upgrade from 67u3 to 7.0 failed
              rpetchim Novice
              VMware Employees

              Vmware SAS controller  with PCI ID - 15ad:1976 is not supported in 7.0 due to vmklinux deprecation.

              Vmware PVSCSI controller - 15ad:07c0 is supported from 7.0.