1 Reply Latest reply on Jun 22, 2020 1:36 PM by daphnissov

    Need help with an issue after reverting vCenter back to a snapshot

    Chipperchoi Lurker

      Hey all,

      I tried to install a couple of updates for JRE on a Windows vCenter server and while it stated that the update was not applicable/needed, it is crashing the vCenter GUI with a 503 error.

      I reverted it back to the snapshot of the VM and while the GUI is now back, there was a warning for perflib in the Event Logs:

      "The configuration information of the performance library "perf-MSSQL$VIM_SQLEXP-sqlctr11.2.5058.0.dll" for the "MSSQL$VIM_SQLEXP" service does not match the trusted performance library information stored in the registry. The functions in this library will not be treated as trusted."

       

      Per the KB article, https://kb.vmware.com/s/article/1004149?lang=en_US&queryTerm=the+functions+in+this+library+will+not+be+treated+as+trusted. I tried to run

      unlodctr "servername" - this ran fine and deleted the content and tried to run lodctr servicename.ini.

      It is returning an error that the ini file does not exist. Now I am getting an error

      "The Open Procedure for service "MSSQL$VIM_SQLEXP" in DLL "perf-MSSQL$VIM_SQLEXP-sqlctr11.2.5058.0.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code."

       

      Am I missing something here as far as the ini file is concerned? I am running both the unlodctr and lodctr command under the Sytem32 directory as an admin.