1 Reply Latest reply on Jun 22, 2020 5:59 PM by Cybertron1984

    Keyboard Indicators out of sync with RDSH App Sessions

    StormFlowers Novice

      Hello All,

      We have recently ran into an issue where the Keyboard Indicators (num lock, caps lock, etc) are out of sync with RDSH App Sessions. In our environment we are running Windows 10 endpoints (1809 and 1909), and Horizon 7.10 on the agent side. We recently upgraded our Horizon Clients from 4.9 to 5.4.2, and this appears to be where the problem lies. Without making any changes on the Agent side (RDSH Farm), I uninstalled the 5.4.2 client and installed the 4.9 client again and then after launching an RDSH App the Keyboard Indicators were back in sync. From here I have by installing each version of the Horizon Client from 4.9 through 5.4.3, and what i found was that the Keyboard Indicators were in sync for the versions 4.9, 4.10, 5.0, 5.1, 5.2, and 5.3, but was out of sync on any 5.4.x version (5.4.0, 5.4.1, 5.4.2, and 5.4.3).

       

      Has anyone else seen this issue after upgrading to any 5.4.x version of the Horizon Client? If so, were you able to find a workaround?

       

      I do have a Support Case open for this, but figured I'd see if others were at least seeing the same. I've tried the various registry entries deployed via UEM\DEM within a test RDSH App Farm session with no luck:

       

      [HKEY_CURRENT_USER\Control Panel\Keyboard]

      "InitialKeyboardIndicators"="2147483650"

       

      [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]

      "InitialKeyboardIndicators"="2147483650"

        • 1. Re: Keyboard Indicators out of sync with RDSH App Sessions
          Cybertron1984 Lurker

          We are seeing the same issue. Except it is only impacting the Num Lock key. Even though the Num lock light is lite, users can't use the numbers from the right side keypad unless they press the num lock key as though they are turning it off and there is not light. Our current work around in the applications section of the horizon client is to change the protocol to PCOIP and selecting the check box underneath that section for Extend to local IME. We noticed this issue after upgrading to 5.4.2 Horizon client. The IME setting seems to force the use of the English keyboard on the local device in the session. Not sure why blast is thinking we have a non English keyboard on our RDSH hosted application servers. Everything is looking like we only have the English keyboard as the option.