1 Reply Latest reply on Jun 12, 2020 10:46 AM by msripada

    VCSA 6.5-6.7 upgrade: A vCenter Single Sign-On endpoint certificate validation error has occured.

    Candell Novice

      Hi all,

      Sorry if this have been discussed before. I couldn't find anything about it and not much at all on the error message on the internet.

       

      I'm upgrading a VCSA running 6.5 to 6.7 using the appliance installer, and the pre upgrade stops with this message:

       

      Error: A vCenter Single Sign-On endpoint certificate validation error has occured.

      Resolution: Ensure that the endpoint service registrations in vmdir match their corrsponding machine SSL certificates in VECS. For more information, see Knowledge Base article KB 2121701.

       

      I recently refreshed the machine certificate that was about to expire, which also required me to accept the certificates on all connected applications such as Horizon View and Veeam-servers, but no other strange issues have been noticed.

       

      The KB 2121701 didn't really seem to match our environment, but I followed the guide and ran the ls_update_certs.py script according to the instructions. It spat out several pages of output, mostly "INFO" but a few "WARN" which always was " com.vmware.vim.vmomi.client.http.impl.HttpConfigurationCompilerBase$ConnectionMonitorThreadBase - Shutting down the connection monitor." and "com.vmware.vim.vmomi.client.http.impl.HttpConfigurationCompilerBase$ConnectionMonitorThreadBase - Interrupted, no more connection pool cleanups will be performed."

       

      Other things I've done is to unregister some old NetApp plugins that we don't use, and also followed the solution in Error when upgrading from VCSA 6.7 to 7.0

       

      Nothing has helped though, and I'm still stuck at the validation stage.

       

      Certificates always make my head spin, and I'd be grateful with some hints on what to check here. We really need to get the VCSA updated, since we've got other things that depend on us having 6.7.

       

      Thanks