2 Replies Latest reply on Jun 10, 2020 8:46 AM by mmaus

    Two root accounts?

    mmaus Novice

      I go into the html GUI of my ESXi host with a local admin account.  I went to Manage > Security & Users > Users and reset the password for the root account.

       

      - I then rebooted the server and on the console screen I can hit the f12 key to Shutdown\Restart and that works fine and allows me to reboot the server. 

      - If I try to login to the GUI with to root account I get an authentication error.
      - If I try to SSH into this host and use root and the same password I get an authentication error...

       

      Are there two different types of root accounts on an ESXi host? 

        • 1. Re: Two root accounts?
          Amin Masoudifard Expert

          Are you sure about the capital "R" in typing "root" credentials...? So if you are, it does not seem to be normal. However, please check the /var/log/auth.log file for more information about whatever happened on the ESXi local account ...

          Please mark my comment as the Correct Answer if this solution resolved your problem
          • 2. Re: Two root accounts?
            mmaus Novice

            Update:
            I reset the password once again to make sure that I didn't fat finger anything.  I rebooted and tried both "Root" and "root" as login.  Instead of logging into Putty this time I just tried to log into the GUI.

             

            - "Root" came back as an invalid user...as expected.
            1.png

            - "root" came back as a access denied.
            2.png

            - Looking into the logs Amin mentions I noticed "pam_access(sshd:auth): access denied for user `root'"

            3.png

            - I found a posting stating to go to /etc/ssh/sshd_config and confirm "PermitRootLogin" was set to yes

            4.png

            - Right clicking on the Host inside the ESXi GUI and selecting Permissions

            5.png

            - I noticed "root" was not listed in this directory

            6.png

            - Adding the root account back here allowed me to SSH back in again.

            7.png