1 Reply Latest reply on Jun 3, 2020 1:25 PM by ashwin_prakash

    Cannot update Skyline

    KennyNoah Lurker
    VMware Employees

      Hi,

       

      I get an error when I try to update skyline

      Current Version: 2.0.0.2

       

      Error:

      Failed to check for updates(Error downloading manifest. Please contact your vendor. OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to vapp-updates.vmware.com:443 URL: https://vapp-updates.vmware.com/vai-catalog/valm/vmw/27152671-6A61-4CA9-A367-15DA44FDAB3F/2.0.0.2.latest/manifest/manifest-latest.xml) on Wednesday, 2020 June 03 14:53:12 UTC+1

       

       

      On The Skyline Viewer, I get the following errors on products such as vcenter and NSX

      Error

      Product validation is supported in Collector version 2.1 or higher, please upgrade to view Product Status. If you're already using the correct version, please open a support request.

       

      Kindly assist

        • 1. Re: Cannot update Skyline
          ashwin_prakash Expert
          VMware EmployeesGS Skyline Support Skyline Community 2/2

          Hello KennyNoah,

           

          Welcome to Skyline Communities !!!

           

          Kindly follow the below-mentioned steps to isolate the issue and upgrade Skyline.

           

          1. Reboot the appliance (Skyline health services are needed to be started for the upgrade to initiate thereby all the required services are started.)
          2. Check the communicate status from Skyline to the VMware VAPP web
            1. Connect to the Skyline virtual machine collector using the VM console
            2. Login with root credentials
            3. Execute the command: curl -v https://vapp-updates.vmware.com:443
            4. Once executed you should see the connection status of the certificate to be Ok.
            5. If the certificate validation is not complete, then check the firewall rule and make sure Skyline Appliance is able to communicate on the network to vapp-update.vmware.com over port 443.