1 2 3 4 Previous Next 47 Replies Latest reply on Jun 10, 2020 9:51 AM by 70nyIT

    Caps Lock Issues With Upgrade

    greylupi Novice

      Good day,

       

      I updated, then tried re-installing the software. Caps is acting weird.

       

      I will type anything and it will be in lower case. *Press CAPS LOCK" and text does change to upper case; however, it will not revert back to lower case when pressing CAPS LOCK again.

       

      Even weirder is when i keep a keypress held down it will pop in a lower case letter randomly (i.e.: DDDDDDDDDDDdDDDDDDdDDDDDDDDDDDDDd)

       

      Is there a way to revert to a previous version of workstation ? or any fix for this ?

       

      Thank you.

        • 1. Re: Caps Lock Issues With Upgrade
          kstatinet Novice

          Same exact issue on my Thinkpad T490. I noticed your post only after I posted mine.

          • 2. Re: Caps Lock Issues With Upgrade
            greylupi Novice

            So the only fix I've found to this for now is reverting back to a previous version. The link is below:

             

            Download VMware Workstation Pro

             

             

            Cheers

            • 3. Re: Caps Lock Issues With Upgrade
              kstatinet Novice

              Thank you. I just tried both Downloads options.

               

              Does not work for me. I receive the following message: "This product installer doesn't support downgrades".

               

              Yesterday, I upgraded to 15.5.5 build-16285975

              • 4. Re: Caps Lock Issues With Upgrade
                Mits2020 Hot Shot

                If the 15.5.x installers don't allow downgrading, then the only way is to uninstall 15.5.5 (+ reboot) and install the old version (+ reboot). It is advisable to disable Shared Folders from your guests, and in case 15.5.5 has a new Tools version (I don't know, I didn't try 15.5.5 yet) and you installed them, remove them too before uninstalling 15.5.5.

                • 5. Re: Caps Lock Issues With Upgrade
                  Mits2020 Hot Shot

                  On second thoughts, unless you absolutely cannot work without Caps Lock control in the guest, you might consider living with 15.5.5 and waiting until VMware produces a fix - judging from recent posts there are also problems with the NumLock key and my guess is that as we speak they are working around the clock for a solution.

                  • 6. Re: Caps Lock Issues With Upgrade
                    kstatinet Novice

                    i agree. the hassle of reinstalling software & vms outweighs waiting. hopefully, it will be a quick turnaround on their part.

                    • 7. Re: Caps Lock Issues With Upgrade
                      kstatinet Novice

                      read the entire thread  about caps lock issue in the older version of VMWare Workstation Pro.

                      they didn't fix it for 3 month after being reported and then suggested to customers to downgrade.

                      this sucks. why to release buggy software in a first place and decide it is not a priority for them to release an update.

                       

                      i don't trust vmware "working around the clock" to fix this. at least, i did not see comments from the dev team on that.

                       

                      thanks vmware for wasting customers time on reinstalling vms.

                      • 8. Re: Caps Lock Issues With Upgrade
                        scott28tt Guru
                        User ModeratorsCommunity WarriorsVMware Employees

                        You shouldn’t need to rebuild VMs if you downgrade, the same as you wouldn’t need to re-type all your documents if you downgraded Word.

                        • 9. Re: Caps Lock Issues With Upgrade
                          elameno Novice

                          Same issue here.  Quite annoying. 

                          • 10. Re: Caps Lock Issues With Upgrade
                            WhiteKnight Hot Shot

                            Here, too. It's currently impossible to work with the guest.

                             

                            I also noticed that it takes quite a long time for VMware Workstation to show the program window after starting VMware Workstation. At first I wasn't sure whether I actually had started the program.

                             

                            I took the liberty to e-mail a support file with full debug logging enabled to Daris.

                             

                            Please provide a fix ASAP. It's currently impossible to run a Windows 10x64 guest on Windows 10x64 host.

                             

                            Here's some more information:

                             

                            With the recent update to VMware Workstation 15.5.5, the enhanced keyboard driver seems to give trouble on Windows 10x64.

                             

                            In Windows 10x64 guests, the modifier keys (ALT, SHIFT, NUM-LOCK) are hanging. They seem to be constantly pressed, rendering using the guest OS impossible.

                             

                            I always have set my Windows OS settings in a way to give a beep sound when one of the modifier keys is pressed. This setting makes me notice when I accidentally press the CAPS-LOCK key, for instance. So, currently, running a guest, I get constant beeps, which is very annoying. Here is a screenshot of my Windows 10 accessibility settings attached. It's in German, but from the position of the highlighted items you may conclude the corresponding English settings. You may find that page at: Windows Settings > Accessibility > Keyboard:

                             

                            Accessibility Settings.png

                             

                            Due to the modifier keys being permanently pressed by the enhanced keyboard driver, Windows 10x64 in the guest suggests to activate the keyboard mouse. Please refer to the following screenshot. It's in German too, I'm afraid:

                             

                            Modifier keys.png

                             

                            In one of the VMs the virtual audio device actually crashed. See this image, depicting the error message:

                             

                            Audio.png

                             

                            Pressing any of these keys doesn't seem to have any effect. The NUM-LOCK LED doesn't toggle.

                            • 11. Re: Caps Lock Issues With Upgrade
                              WhiteKnight Hot Shot

                              It looks like the error is intermittend, at least in one of my guest machines. After running the VM for a while and dismissing the Keyboard Mouse confirmation message, I seem to be able to work with that particular guest.

                               

                              While the numerical keypad still doesn't work, the beeping has stopped and I seem to be able to work with the VM (except for not being able to input numerical values using the keypad).

                              • 12. Re: Caps Lock Issues With Upgrade
                                kstatinet Novice

                                yeah.. downgraded to 15.5.2 problem solved.

                                • 13. Re: Caps Lock Issues With Upgrade
                                  justaguy2 Lurker

                                  Temporary solution for Ubuntu guest which worked for me was just disabling the Caps Lock key all together with this

                                   

                                  setxkbmap -option caps:none

                                  • 14. Re: Caps Lock Issues With Upgrade
                                    DrJfrost Lurker

                                    I have the same problem on Manjaro OS seems I will have to downgrade too :s

                                    1 2 3 4 Previous Next