4 Replies Latest reply on May 28, 2020 6:35 AM by tpc1337

    Self-Support tool not resetting application settings

    tpc1337 Lurker

      Hi,

       

      We are in the process of deploying VMware DEM in our environment. So far everything is working fine, except for the Self Support tool. I did some tests with it and noticed that in the FlexEngine.log application settings were reset, but when our user account starts the application the settings are still there. I am using DirectFlex for the mentioned application. I also did tests  with the "Windows Common Setting" for the taskbar, and it had the same effect. FlexEngine.log shows that there is no profile archive to import for the specified config file, so I'm assuming that the cleanup actually worked. But when I logoff and logon again, the application settings are still there. Maybe I am missing something, so that's why I decided to post this on the forum.

       

      Regards

        • 1. Re: Self-Support tool not resetting application settings
          DEMdev Master
          VMware Employees

          Hi tpc1337,

          FlexEngine.log shows that there is no profile archive to import for the specified config file, so I'm assuming that the cleanup actually worked.

          That indicates that the Self-Support Tool has indeed correctly reset that profile archive.

           

          If the settings are still available in the user's profile without having been imported from that profile archive, maybe they were also captured in another profile archive? Or maybe they are part of the "base" Windows profile? What type of Windows profile do you use?

          • 2. Re: Self-Support tool not resetting application settings
            tpc1337 Lurker

            We use persistent VDI's where users have their own profile. As long as they work in the same VDI, the profile settings are saved on that VDI. When users get assigned a new VDI their profiles are gone and so are all their environment settings. Thats why we are currently working towards implementing VMware DEM so that users' settings will be persistent across newly assigned VDI's. We implemented the DEM environment exactly as stated in the VMware docs. Like previously mentioned, all other things are working fine. We profiled 2 applications and added 4 common Windows settings in the Management Console, this all works great and is tested with several users. It's only the self support tool that we can't seem to get working properly.

            • 3. Re: Self-Support tool not resetting application settings
              DEMdev Master
              VMware Employees

              Hi tpc1337,

              We use persistent VDI's where users have their own profile.

              That would explain the behavior you're seeing.

               

              When DEM saves settings into a profile archive, they remain in the user's Windows profile. In a persistent scenario where the user logs back on to the same machine, those settings are still available for the user's next logon, without the need for DEM to do anything. Resetting settings in the Self-Support Tool just deletes the corresponding profile archive, but that won't have any effect if those settings are still available in the Windows profile.

               

              If you want the profile archive reset functionality to be effective in persistent scenarios, you can use the Profile Cleanup feature to delete the application-specific profile information at each logoff (or application exit for DirectFlex) or use the Predefined Settings feature to configure the default settings.

              1 person found this helpful
              • 4. Re: Self-Support tool not resetting application settings
                tpc1337 Lurker

                Hi DEMdev,

                 

                Spot on! It was indeed due to config files being read in the user profile itself. On the DEM part everything went well. I'm doubting if we will be using the cleanup tool, since we've to manually look up every regkey/file location of every application in order for the cleanup tool to work properly. Thanks for your quick response!

                 

                Regards