1 Reply Latest reply on May 25, 2020 8:32 AM by Gabrie

    vCloud setup failing

    Gabrie Master
    vExpert

      Sigh…. vCloud deployment keeps failing me whatever I try. I’m deploying the OVA appliance as primary small node, but it keeps failing the installation. After the OVA is deployed, I get the message: “No nodes found in cluster, this likely means PostgreSQL is not running on this node. Consult the management UI from another node where PostgreSQL is running. Otherwise, check /opt/vmware/var/log/vcd/vcd_ova_ui_app.log if you think this is an error.“.

       

      When I check the logs, I find the following info:

      setupvcd.log

      2020-05-25 13:54:25 | Mounting NFS file share...

      2020-05-25 13:54:36 | System ip0 is: 10.248.1.15

      ls: cannot access ‘/opt/vmware/vcloud-director/data/transfer/appliance-nodes’: No such file or directory

      ls: cannot access ‘/opt/vmware/vcloud-director/data/transfer/cells’: No such file or directory

      2020-05-25 13:54:36 | Invoking appliance-sync.sh now...

      2020-05-25 13:54:41 | Configuring vCD from OVF properties as initial cell...

      2020-05-25 13:54:41 | Configuring the embedded PostgreSQL database...

      2020-05-25 13:54:41 | Creating PostgreSQL user (vcloud) and database (vcloud)...

      CREATE ROLE

      ALTER ROLE

      ALTER ROLE

      CREATE DATABASE

      2020-05-25 13:54:42 | DB Host value is 10.248.1.25

      .......................................\

      Database configuration complete.

      2020-05-25 13:55:31 | Copying local responses.properties to NFS.

      2020-05-25 13:55:31 | Invoking firstrunwizard.sh now...

      2020-05-25 13:55:35 | [ERROR] Failed to run firstrunwizard.sh. See /opt/vmware/var/log/vcd/firstrunwizard.log for details. Aborting.

       

       

      Looking at the NFS share, I do see the following contents:

      root@vasdb001 [ /opt/vmware/var/log/vcd ]# ls -l /opt/vmware/vcloud-director/data/transfer/

      total 8

      drwxr-xr-x 3 vcloud vcloud 4096 May 25 13:54 appliance-nodes

      -rw------- 1 vcloud vcloud  427 May 25 13:55 responses.properties

       

      So install was able to write something in the NFS share. Permissions on NFS should be correct I think.

      Looking in ” /opt/vmware/var/log/vcd/firstrunwizard.log”

      2020-05-25 13:55:32 | Running the system-setup CMT command ...

      Unexpected error parsing command line options:

      Missing argument for option: email

      usage: system-setup

          --email <arg>             Required - Admin email

          --full-name <arg>         Required - Admin fullname

      -h,--help                    Print this message

          --installation-id <arg>   Required - Installation ID. Range: [1..63]

          --password <arg>          Required (if unattended mode) - Admin

                                    password

          --serial-number <arg>     Optional - License serial number

          --system-name <arg>       Required - System name

          --unattended              Optional - Unattended mode does not prompt

                                    for the administrator password, which you

                                    must supply on the command line.

          --user <arg>              Required - Admin username

      2020-05-25 13:55:35 | [ERROR] system-setup failed possibly due to above error(s). Aborting.

       

      Tried this with OVA VMware_Cloud_Director-10.1.0.4837-15967253_OVF10 and VMware_vCloud_Director-10.0.0.4649-15450333_OVF10.

        • 1. Re: vCloud setup failing
          Gabrie Master
          vExpert

          Issue has been solved..... turns out the e-mail address that is asked for in the OVA wizard is a requirement. i left it blank because SMTP hadn't been setup yet and I wanted to enter the e-mail address later on.

          1 person found this helpful