1 Reply Latest reply on May 20, 2020 2:10 AM by mf_SVA

    Horizon Cloud on Azure - Unable to register Active Directory

    mf_SVA Lurker

      Hello everybody,

       

      i'm currently trying to set up a Horizon Cloud Environment with Azure resources. I basically followed the instructions from these sources:

       

      From Zero to Hero:  A Step by Step Guide How To Deploy Horizon Cloud Service on Azure - YouTube

      Quick-Start Tutorial for VMware Horizon Cloud Service on Microsoft Azure | VMware

       

      So what i did is, i set up all the network requirements on Azure, set up my local DNS Server in the VNET Settings, created a service principal on Azure, the IPSEC Tunnel from Azure to my on premises environment is up and running and also the POD Deployment from Horizon Cloud to Azure was successful. The next step would be to connect my local Active Directory and here i stuck at the moment.

       

      The error message says "Unable to register Active Directory" as shown in the following picture:

       

      Image 749.png

       

      For troubleshooting purposes it created a small Windows 10 VM on Azure and configured it with Network Settings from i.e. the MGMT Subnet which i created earlier for my Horizon on Azure Deployment. From that VM i can access different resources on my local Environment via the IPSEC Tunnel without any problems. So there shouldn't be an network issue.

       

      Does someone have had the same issues or any idea what to check or where the problem could be? i'd really appreciate any help!

       

      Thank you in advance.

      Best Regards,

      MF

        • 1. Re: Horizon Cloud on Azure - Unable to register Active Directory
          mf_SVA Lurker

          Hey,

           

          here's a little update on this:

          • Connection to the local Domain Controller from Horizon Cloud still doesn't work, but i can join a Azure Test VM into my local Domain without any problems
          • I deployed a Server 2016 VM on Azure and configured it to be an additional Domain Controller for my local AD. After i did this i could register my local AD on Horizon Cloud with my local domain bind / domain join Accounts. From there i could finally set up the Cloud Pod and everything worked perfectly

           

          So that's a workaround for now and definitely not the final solution. I'm still trying to figure out what the problem with the AD join via the IPSEC Tunnel ist and why it's not working as expected.

          The different Active Directory deployment options are listet here:

           

          The VMware recommended one is Option 6. So i'll try to set this up as well but event if that workes, i'll want to get option 1 running as well.

           

          I still appreciate any help from your side.

          Thanks.

           

          Regards,

          MF