0 Replies Latest reply on May 13, 2020 8:55 AM by Mits2020

    Solution: New Workstation 15.5.x installation problems due to VC++ redistributables

    Mits2020 Enthusiast

      I am posting this for posterity, since I was surprised I did not find anything relevant in the VMWare Communities or other sites.

       

      Today I needed to install the latest Workstation v15.5.2 (build 15785246) in a new Windows PC (Windows 10 Enterprise) I was setting up for a client, which was fully patched to the latest (as of today 13.5.2020) updates.

       

      The problem I encountered was that the installation insisted that it needs to reboot because of a pending VC++ installation, in the lines of the (still unanswered) thread  https://communities.vmware.com/thread/604431 and https://communities.vmware.com/thread/618794.

       

      I rebooted several times but the problem did not go away.

       

      So I decided to go with the suggested solution in the  2nd thread which credits https://www.vgemba.net/vmware/Workstation-15.5-Install-Error/. That thread suggests installing the latest x86 and x64 2015-2019 VC++ redistributables provided by MS in https://support.microsoft.com/en-gb/help/2977003/the-latest-supported-visual-c-downloads

       

      I installed those and the problem still persisted.

       

      As suggested elsewhere, I tried uninstalling the above updates but then many things initially refused to run (e.g. Firefox) and after a few seconds settled because Windows automatically reinstalled them. Still not able to install WS.

       

      I dug some more and some other threads elsewhere seemed to indicate that this and other installation problems arise from the Windows 10 October 2019 updates, that the problems are still not fully resolved, and that if the Oct 2019 updates are temporarily uninstalled one can proceed. From bitter experience I decided to avoid messing with the Windows update system at all cost and dig some more.

       

      I even tried the previous build 15.5.1-15018445 with the same results.

       

      Then I suddenly remembered the WS installation .exe had some run time switches and looked them up in the hope that there may be an option to bypass the VC++ checks. There were options but nothing like the one I hoped. Then I saw the /x option to unpack the file and thought that I could perhaps deal better with smaller installation files.

       

      So I used the /x option, i.e. "VMware-workstation-full-15.5.2-15785246.exe /x" which decompresses the big executable in %temp%, that is C:/Users/_myusername_/Appdata/Local/Temp and there I found 3 files: The main executable .msi, and the two VC++ x86 and x64 required updates, which, if not present in the system, are installed by VMware. So I just ran the .msi (ignoring the rest) and the installation proceeded flawlessly!

       

      TLDR: IF you are installing VMWare for the first time, and IF the expected by VMWare versions of VC++ for some reason do not match the installed ones, OR IF the OS for some reason refuses to install the ones provided by VMWare, we are at a dead end. SOLUTION: Install the latest VC++ versions from Microsoft provided above, decompress the .exe file with the /x switch and run the .msi installer instead.

       

      Some thoughts and suggestions: If the rate at which Microsoft updates the VC++ runtimes exceeds the rate of VMWare build releases rate, I would expect that the problem will reappear in the future, mainly for users installing VMWare for the first time. If the problems become more frequent, in order to avoid user frustration:

       

      1. We could have simpler installers with less strict prerequisites checking. I think that users would not really mind following installation instructions in a README to manually install any prerequisites like VC++ before installing VMWare Workstation or Player, instead of having it all automated by the VMWare installer.

       

      2. Another idea would be implementing a small standalone compatibility checker to check if the target system meets all the prerequisites needed.

       

      I hope the above information is of help!