8 Replies Latest reply on Jun 24, 2020 7:23 AM by mnvasquez

    Dell R710 not compatible with vSphere 7.0

    marcwa19197 Lurker

      Hello,

       

      im using an Dell R710 in an Lab installation running very well with vSphere 6.7 Dell-Customized. (Image Profile: DellEMC-ESXi-6.7U3-15160138-A03)
      This Dell R710 has two Intel XEON E5620 CPUs.

       

      I know, even in vSphere 6.7 there was an warning about that old CPU which might not be supported anymore in future releases (7.0).

       

       

      i tried a few things to do the update vSphere 6.7 to vSphere 7.0:
      - Dell Customized 7.0 iso (booted from iso and tried update via the GUI)
      - Dell Customized 7.0 Offline Bundle (Via esxcli command line)
      - VMware official 7.0 Offline Bundle (Via esxcli command line)
      --> Every try ended up with the errormessage "CPU is not supported" on the 6.7 release this was only an warning, which could be skipped.

       

      Is there really no way to get it installed (even no "unsuportted" way)?
      Is it only the CPU which might be unsupported? So maybe an switch to an newer CPU (Which is also able to run in the R710) i an possible way?

       

      Thank you.

        • 1. Re: Dell R710 not compatible with vSphere 7.0
          scott28tt Champion
          User ModeratorsCommunity WarriorsVMware Employees

          Seems like it was 6.5 that last supported your CPU, it doesn't show for 6.7 or 7.0:

           

          VMware Compatibility Guide - cpu

           

          And your R710 was last supported on 6.0:

           

          VMware Compatibility Guide - System Search

           

          You'd probably also have issues with IO devices as a lot of older drivers have been deprecated in 7.0.

          • 2. Re: Dell R710 not compatible with vSphere 7.0
            marcwa19197 Lurker

            Thank you for the information links.
            Yes, i know this old Server is unsupported. But i was able to upgrade 6.5 to 6.7 using the dell customized iso and did the upgrade via GUI.
            There was the warning about my old CPU, but i was able to skip it. This skip seems to not work on 7.0 anymore :-(

             


            I read a bit in the internet, there is an way to bypass the "CPU Check".
            I will maybe give it a try, if there is no other "cleaner" way.

            • 3. Re: Dell R710 not compatible with vSphere 7.0
              scott28tt Champion
              VMware EmployeesUser ModeratorsCommunity Warriors

              I suspect the lack of "vmklinux" drivers will still be an issue, even if you could find a workaround for the CPU.

              1 person found this helpful
              • 4. Re: Dell R710 not compatible with vSphere 7.0
                IRIX201110141 Master

                Even a clean 6.7 installation would not work because of the CPU Check. Under circumstances you can perform an inplace upgrade form 6.x to 6.7 but 7.0 is a new major release and the CPU Check is in place.

                If you read the other posts you will see that the people have problems with 12Gen. as well when is comes to onboard NICs like BCM5720 and H310 PERCs.

                 

                Regards,
                Joerg

                1 person found this helpful
                • 5. Re: Dell R710 not compatible with vSphere 7.0
                  SMcT Lurker

                  I read about using Workstation on your desktop to install ESXI 7.0 to a USB drive.  Once installed, remove it from your PC and boot your R710 from the USB. I haven’t personally tried it but the guy who wrote the blog had success. If I can find the link I’ll post it, but he didn’t do much more than I’ve mentioned above. Hope you get some success and get a bit more time out of your lab kit!

                  • 6. Re: Dell R710 not compatible with vSphere 7.0
                    marcwa19197 Lurker

                    Hi, thank you!
                    So to understand it correctly if i follow your workaround.
                    I will end having an fully installed esxi bootable usb stick, where i will boot my R710. So i will just swap the current installation 6.7 with the new usb stick installation 7.0?

                     

                    Generall Question: are there any settings i need from the older 6.7 installation? (Or is everything stored on vcenter vm?)
                    (I only have the perccli tool in mind, which is installed directly on the esxi host)

                     

                    Thanks!

                    • 7. Re: Dell R710 not compatible with vSphere 7.0
                      IRIX201110141 Master

                      If you append allowLegacyCPU=true  to the kernel boot option you can work around the cpu check.  But please expect other problems related to PERC and NIC.

                       

                      Regards,
                      Joerg

                      • 8. Re: Dell R710 not compatible with vSphere 7.0
                        mnvasquez Lurker

                        I've been working on a similar issue. I have a Dell R710 with an H700 Raid controller, and dual Xeon 5570's, and wanted to install ESXi 7.0. It's currently a Win2k19 server. Here's where I got to....

                        Tried installing 6.7: Dell custom image worked, but CPU's not supported, and AllowLegacyCPU=true not supported.

                        So, on 7.0: AllowLegacyCPU=true works, however, when it goes to install ESXi, it doesn't see the H700, thus, no where to install to... BUT

                        It does see the USB stick i booted from. So, I added a 2nd USB stick, and installed to that, thinking I could then copy the installed image to the Drives on the H700 at some point -- that's where I'm at now.

                        Note that at first boot off the USB, I need to hit Shift O and add AllowLegacyCPU=true, and will need to add that into the boot files so I don't need to do it each time. But hopefully that helps give you a path to getting it all working...