2 Replies Latest reply on Apr 26, 2020 3:42 PM by dbalcaraz

    VCSA 6.7 to 7.0 migration failure

    Barracksbuilder Lurker

      I am trying to upgrade my lab VCSA 6.7.0.43000 to 7.0. It always fails on the migration part. It fails on firstboot starting the sps service.

       

      I attached the log from sms_spbm_firstboot.py_35481_stderr.log. It does not seem to help very much I have searched several KB errors for failing to start SPS but no luck. This lab is out of my Vmug account so I'm not entitled to support however, my company I work for does have support so it may be a gray area of actually getting support from vmware. I normally test things in my lab before doing things in production.

       

      Any Ideas or any other logs needed just let me know.

        • 1. Re: VCSA 6.7 to 7.0 migration failure
          dbalcaraz Expert
          vExpert

          Hi,


          The only thing I see related is this KB: VMware Knowledge Base

          Hope it gives you a clue.

          • 2. Re: VCSA 6.7 to 7.0 migration failure
            Barracksbuilder Lurker

            I came across that KB also but it didn't seem to help. I was unable to locate the cmfirstboot.py_####_stderr.log file. My analytics_firstboot.py_####_stderr.log is empty and the stdout says: "2020-04-25T07:32:07.793Z  VMware Analytics Service firstboot finished". My vpxd_firstboot.py_####_stdout.log has no error the last line is: 2020-04-25T07:37:09.140Z  VirtualCenter firstboot successfully finished. My pschealth-firstboot.py_#####_stderr.log has some items but doesn't really say error:

            2020-04-25 07:34:00,666 INFO 71 PSCHealth FBActions.FIRSTBOOT

             

            2020-04-25 07:34:00,679 INFO 73 SCA Registration completed successfully

            2020-04-25 07:34:02,029 INFO 115 Done with pschealth firstboot

             

            Obviously then the sms_spbm_firstboot.py_####_stderr.log has the errors and that's when it seems the installer blows out.

             

             

            vmafdd-syslog.log Shows no error and the last line is: 2020-04-25T07:29:16.021Z  VMAFD Boot Succeeded

             

            vapi_firstboot.py_####_stderr.log error file is blank stdout:

            2020-04-25T07:32:51.928Z  Successfully started vapi-endpoint service

             

            2020-04-25T07:32:51.928Z  Done with vapi firstboot

             

            mgmt-firstboot.py_####_stderr.log is empty, stdout:

            2020-04-25T07:37:27.759Z  Successfully started applmgmt service

             

            2020-04-25T07:37:27.759Z  Service setup completed successfully

             

            scafirstboot.py_####_stderr.log is empty, stdout:

             

            2020-04-25T07:32:38.310Z  Successfully started sca service

            2020-04-25T07:32:38.310Z  Done with sca firstboot

             

            updatemgr-firstboot.py_6012_stderr.log does not exist.

             

            ngc_firstboot.py_####_stderr.log does not exist.

             

            fbInstall.json

             

               "start_time": "2020-04-25T07:27:57.541Z",

             

               "end_time": "2020-04-25T07:50:39.726Z"