3 Replies Latest reply on Apr 23, 2020 4:25 AM by sxnxr

    vROPS 8.0 Admin page error 403

    thompsoa Novice
    vExpert

      Hi All,

       

      Any idea why https://vROPS/admin reports the following error? /UI works fine

       

      Version 8.0.0.14857692

      Thanks!

        • 1. Re: vROPS 8.0 Admin page error 403
          sxnxr Expert
          vExpert

          The admin UI and the product UI both use the Apache2 service (think it is still the same in the later versions) but two separate instances/services that is why you can have one running and the other not.

           

          You can check the state of the services. Iam not sure of the CLI someone else may post it here but i use the REST api

           

          https://insert you vrops node/suite-api/api/deployment/node/services/info

           

          you will get this. It will show you if the service for the adminUI is stopped. You could command line it to try and start it but i would have to google the command.

           

          "service": [

                  {

                      "name": "LOCATOR",

                      "health": "OK",

                      "details": "Success, Service LOCATOR is running and responding",

                      "uptime": 605626174,

                      "startedOn": 1586945859917

                  },

                  {

                      "name": "ANALYTICS",

                      "health": "OK",

                      "details": "Success, Service ANALYTICS is running and responding",

                      "uptime": 605616425,

                      "startedOn": 1586945873083

                  },

                  {

                      "name": "API",

                      "health": "OK",

                      "details": "Success, Service API is running and responding",

                      "uptime": 605612851,

                      "startedOn": 1586945873337

                  },

                  {

                      "name": "ADMINUI",

                      "health": "OK",

                      "details": "Success, Service ADMINUI is running and responding",

                      "uptime": 605632817,

                      "startedOn": 1586945853468

                  },

                  {

                      "name": "EPOPS",

                      "health": "OK",

                      "details": "Success, Service EPOPS is running and responding",

                      "uptime": 605612968,

                      "startedOn": 1586945873337

                  },

                  {

                      "name": "UI",

                      "health": "OK",

                      "details": "Success, Service UI is running and responding",

                      "uptime": 605632845,

                      "startedOn": 1586945853468

                  },

                  {

                      "name": "COLLECTOR",

                      "health": "OK",

                      "details": "Success, Service COLLECTOR is running and responding",

                      "uptime": 605614780,

                      "startedOn": 1586945871585

                  },

                  {

                      "name": "CASA",

                      "health": "OK",

                      "details": "Success, Service CASA is running and responding",

                      "uptime": 605846377,

                      "startedOn": 1586945640197

                  },

                  {

                      "name": "CASSANDRA",

                      "health": "OK",

                      "details": "Success, Service CASSANDRA is running and responding",

                      "uptime": 605672816,

                      "startedOn": 1586945813605

          • 2. Re: vROPS 8.0 Admin page error 403
            NZVSS Lurker

            <ops:service name="ADMINUI" health="ERROR">

            <ops:details>Service ADMINUI not responding</ops:details>

            </ops:service>

             

            Cannot find the command to restart it

            • 3. Re: vROPS 8.0 Admin page error 403
              sxnxr Expert
              vExpert

              If this is a multi node cluster can you connect to a data node admin UI to take the cluster offline

               

              also

               

              VMware Knowledge Base