11 Replies Latest reply on Apr 29, 2020 7:26 AM by nachogonzalez

    vSphere 6 standard - sso

    DJChaz Lurker

      The admin walked out the door and I have no access other than RDP into the server and use my windows login.

      Any advice on how to promote to have the sso role. My backup server cant login remotely to run back ups.

       

      I used to be able to run the client from my desktop and login using my admin account. But now I can only run the client from the actual server.

      Any advice or documentation to help me get this function back?

       

      Thanks!

      DC

        • 1. Re: vSphere 6 standard - sso
          a.p. Guru
          User ModeratorsvExpertCommunity Warriors

          Welcome to the Community,

           

          to find out what can be done, please provide some details:

          • what's the vCenter Server version, and build number?
          • is it the Windows based version, or the vCenter Server Appliance (a Linux based VM)?
          • are you still using the Windows client, or the web client?
          • is it the "administrator@vsphere.local" that you need to reset?

           

          You say that the backup doesn't work either. Is the backup configured to use the administrator@vsphere.local account? In this case you may consider to change that to a separate account once the access/login issue is fixed..


          André

          • 2. Re: vSphere 6 standard - sso
            DJChaz Lurker

            Hi Andre!

            I have VMware Vsphere client 6.0.0 build 3016447

            running on Windows Server 2012 R2

             

            The web client or the windows client will not connect unless you have checked the box "use windows session creds"

            If I uncheck that box and type in the exact credentials it will not log in.

            "Cannot complete login due to an incorrect user name or password"

             

            I believe my Barracuda Backup source is having the same issue.

            When I test its creds from the appliance it cant connect to the VMserver.

             

            I am not sure if I need the vsphere local admin reset or not.

            I'm just wondering what happened to my ability to login from the outside to the Vsphere client.

            I checked the services and I didnt see any vmware.sso type running. So now Im not sure it has sso.

            • 3. Re: vSphere 6 standard - sso
              a.p. Guru
              Community WarriorsUser ModeratorsvExpert

              If there are no active tasks (migrations, or other things) running on vCenter Server, is it possible to reboot the server, to see whether this resolves the issue?


              André

              • 4. Re: vSphere 6 standard - sso
                scott28tt Champion
                User ModeratorsCommunity WarriorsVMware Employees

                Moderator: Moved to the vCenter Server area

                • 5. Re: vSphere 6 standard - sso
                  DJChaz Lurker

                  Thanks Andre!

                  I am working to get the permission to reboot!

                  I will let you know if I have any success.

                   

                  Thanks!

                  David

                  • 6. Re: vSphere 6 standard - sso
                    DJChaz Lurker

                    Good Morning Andre!

                    So I was able to reboot the server but still have no luck connecting from the client windows or web!

                    I can RDP into the server and start the client but it will only connect using the "Use Windows session credentials" check box.

                     

                    It must use a cached account because I add the exact login information and it gets an error if I uncheck that box.

                    If unchecked I get an "untrusted SSL certificate is installed   (not sure if that is affecting it or not)

                    I have tried installing it in trusted root a few times and doesnt seem to make a difference.

                     

                    Do you know who I would contact to help gain access to the root or local.administrator?

                     

                    Thank you for your help!

                    David Chastain

                    • 7. Re: vSphere 6 standard - sso
                      a.p. Guru
                      User ModeratorsCommunity WarriorsvExpert

                      Didn't the admin document anything, e.g. the admin password?

                      Did you check the server's event logs after the reboot, to see whether it contains any related entries?

                      Did you try to login with or without specifying the domain, i.e. "domain\username", or just "username"? The domain may be required if it's no set as the default within the vCenter Server configuration.


                      André

                      • 8. Re: vSphere 6 standard - sso
                        DJChaz Lurker

                        Good Morning!

                        Unfortunately the information I have is not accurate.

                        I have attempted to contact him but (believe it or not) he is not answering!

                         

                        I have tried several variations of my known good login information.

                         

                        I downloading the system logs now but it seems to be very large! ..5 minutes and its at 3%

                         

                        Anything in particular I should be looking for in the logs?

                         

                        Should I have a SSO service running?

                        • 9. Re: vSphere 6 standard - sso
                          BenediktFrenzel Enthusiast
                          VMware EmployeesvExpert

                          Hi,

                           

                          could you kindly attach a screen shoot of the Services Running of the output of service-control --status

                           

                          VMware Knowledge Base

                           

                          // Thanks,

                           

                          Ben

                          • 10. Re: vSphere 6 standard - sso
                            DJChaz Lurker

                            HI Ben!

                            I have attached the output of the --status

                            Thank you in advance for your help!

                            David

                            • 11. Re: vSphere 6 standard - sso
                              nachogonzalez Enthusiast

                              I think what you need is this KB https://kb.vmware.com/s/article/2146225   on how to reset administrator@vsphere.local credentials

                               

                              Hope this works