4 Replies Latest reply on Apr 5, 2020 2:52 AM by bruste

    Guest NAT network works intermittently

    bruste Lurker

      Hi,

      I've got an issue with all my guest VMs (win7 and win10), NAT network works intermittently. If I run a ping /t to an ip address for a while ping responds successfully, then for a while goes in timeout then restarts to works. This behavior happens both with local addresses and internet addresses, also if I try to ping default gateway.

      Obviously my problem is not with ping, but this issue involves all communications with every protocols.

      I've already tried to:

      - Uninstall vmware workstation and reinstall it

      - Restore default setting in virtual network editor

       

      I don't know how to fix this issue, unfortunately I need nat network, I cannot use bridged one.

       

      Guest ipconfig

       

         Connection-specific DNS Suffix  . : localdomain

         Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection

         Physical Address. . . . . . . . . : 00-50-56-35-6D-4D

         DHCP Enabled. . . . . . . . . . . : Yes

         Autoconfiguration Enabled . . . . : Yes

         Link-local IPv6 Address . . . . . : fe80::24a4:10f8:d54:2fde%21(Preferred)

         IPv4 Address. . . . . . . . . . . : 192.168.193.128(Preferred)

         Subnet Mask . . . . . . . . . . . : 255.255.255.0

         Lease Obtained. . . . . . . . . . : domenica 5 aprile 2020 09:50:55

         Lease Expires . . . . . . . . . . : domenica 5 aprile 2020 11:20:56

         Default Gateway . . . . . . . . . : 192.168.193.2

         DHCP Server . . . . . . . . . . . : 192.168.193.254

         DHCPv6 IAID . . . . . . . . . . . : 335564886

         DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-41-26-90-00-0C-29-49-E4-40

         DNS Servers . . . . . . . . . . . : 192.168.193.2

         Primary WINS Server . . . . . . . : 192.168.193.2

         NetBIOS over Tcpip. . . . . . . . : Enabled

       

      I've attached two pings result, to show what it's happening on my VM and also my network configuration

       

      I'm using VMWare workstation PRO 15.5.2 installed on windows 10

       

      Any idea how to solve this issue ?

      Thanks in advance

        • 1. Re: Guest NAT network works intermittently
          dariusd Virtuoso
          VMware EmployeesUser Moderators

          If you also encounter problems when pinging between two machines attached to the NAT network (other than the NAT gateway at .2 and the NAT host interface at .1), I would start by checking for duplicate MAC/IP addresses on the NAT network.  Having two VMs with the same MAC address will cause just this sort of intermittent communication failure.

          --

          Darius

          • 2. Re: Guest NAT network works intermittently
            a.p. Guru
            User ModeratorsvExpertCommunity Warriors

            Welcome to the Community,

             

            please take a look at the host's as well as the guest's Event Logs to see whether they contain related entries.

            What kind of A/V or Endpoint Security application do you use? Just want to rule out that this blocks traffic.

             

            André

            • 3. Re: Guest NAT network works intermittently
              bruste Lurker

              Thanks Dariusd for the answer.

              I'm facing this issue also at home, where there aren't other vms running in the network.

              However I also tried to regenerated the mac address but the issue persists.

               

              Pinging the gateway the issue doesn't occur, it seems the only address (at least between the addresses I tried) that works well.

              • 4. Re: Guest NAT network works intermittently
                bruste Lurker

                It's a corporate pc with installed McAfee end point security and also ZScaler security, unfortunately I cannot do pretty much anything on that software. Calling helpdesk of my company it's a lost war...

                I also think that it can be another software that blocks vmware network but I didn't find any evidence of that