5 Replies Latest reply on Apr 8, 2020 9:29 AM by david3b507

    No network in Virtual Machine

    NCu Lurker

      So thanks to the lockdown due to covid-19, I've been building a new home lab. (ESXi 6.7u3) with two HP Z600's with additional NIC cards etc. etc.


      Anyhow, all 3 NICs show up in the ESXi Networking screen in Physical NICs. vSwitch0 shows 2 port groups, 3 uplinks.  I have VM Network (vmk1) and Management Network (vmk0) in the port groups showing with Active ports and connected to vSwitch0.  TCP/IP stack shows VMKernel NICs.


      At this stage all looks good, I can access the esxi on the IP set in the Management Network (vmk0).  I configured vmhba64 in storage adapters, configured the Software iSCSI, and connected my NAS, and it shows up fine in Storage as a Datastore, which I can browse. and upload ISO image to.  All looking good still.


      So, go to create a new Virtual machine, Select name, compatibility 6.7 virtual machine, Guest OS, OS family, Guest OS version, select datastore (local VMFS6), virtual hardware.  This is where I hit a brick wall.  Network Adapter 1 is greyed out, no drop-down.  I can expand and select Status, Adapter type and MAC address bits, bit no drop down not the Network Adapter to select VM Network.


      On the iSCSI NAS, I placed a previously build and used VM and then imported that, and in the Network adapter if shows as "VM Network (Disconnected)" .  If I got to edit the VM under network adapter this is now also greyed out an has no value in there.


      This is the same on both boxes.  I tried a reset of the netowrking, and then just adding a VM with the default DHCP on the server management address and again got the same issue.


      Given the access to ESXi and that the iSCSI connection to the NAS works, iI don't think it's a problem with the physical NICs, and one of these actually worked fine before on ESXi 6.5x (I did a clean install to 6.7 and not an upgrade - silly me!).

        • 1. Re: No network in Virtual Machine
          daphnissov Guru
          Community WarriorsvExpert

          You do not need a vmkernel port for "VM Network" as this is what is blocking that port group from being used.

          • 2. Re: No network in Virtual Machine
            scott28tt Champion
            Community WarriorsVMware EmployeesUser Moderators

            VM Network is supposed to be a VM Port Group, for connecting the vNICs of VMs to.


            By adding a VMkernel port to it you have stopped it from being a VM Port Group, so now you have no VM Port Groups.

            • 3. Re: No network in Virtual Machine
              NCu Lurker

              Thanks folks,


              What I was attempting to circumvent was the issue that the original NIC on the motherboard doesn't seem to support jumbo frames.  So I was aiming to put management on that NIC and everything else on the other two NIC's with jumbo frames and teaming.


              Once I put everything back to MTU 1500 and all three NICs on the single vSwitch, for ome reason I'm seeing time out errors in the iSCSI  even with just a crossover cable between the NAS and the server.  Back to the drawing board then...

              • 4. Re: No network in Virtual Machine
                scott28tt Champion
                User ModeratorsCommunity WarriorsVMware Employees

                If you can (and want to) use the same physical NICs, you can add a VM Port Group to the vSwitch and call it whatever you want - you'll then have a VM Port Group that you can connect VM NICs to.

                • 5. Re: No network in Virtual Machine
                  david3b507 Lurker

                  Hi NCu,


                  You can create two virtual switches, one using the embedded NIC as uplink and a VMkernel port for management, and the other one for your iSCSI network using the two adapters that support jumbo frames. While creating the new virtual switch you can create a virtual machine port group to attach the virtual machines adapters, then create a new VMkernel port on that second switch. This will give both your ESXi host and your VMs access to the iSCSI network.


                  You could use a single virtual switch but you may have to override the default virtual switch failover policy on each VM Port Group and VMkernel to use a different uplink to exit the virtual switch.