8 Replies Latest reply on Mar 27, 2020 8:32 AM by bewe

    Cant login to Appliance Management

    Niclas_nrk Lurker

      I have a vcenter v6.5 where I can login with root to the console but I cannot login to Appliance Manager. I get "Unable to authenticate. Try again." I did a passwd but that did not help

       

      chage -l root

      Last password change                                    : Mar 27, 2020

      Password expires                                        : Mar 27, 2021

      Password inactive                                       : never

      Account expires                                         : never

      Minimum number of days between password change          : 0

      Maximum number of days between password change          : 365

      Number of days of warning before password expires       : 7

       

       

      Any idea how to fix this?

        • 1. Re: Cant login to Appliance Management
          a.p. Guru
          User ModeratorsvExpertCommunity Warriors

          One issue that I ran into a few weeks ago is https://kb.vmware.com/s/article/68149.

          Please check whether the "applmgmt" service is started.


          André

          • 2. Re: Cant login to Appliance Management
            Niclas_nrk Lurker

            applmgmt is started, but I tried to restart it but I get the same message (Unable to authenticate. Try again.) trying to login

            • 3. Re: Cant login to Appliance Management
              bewe Expert

              do you see errors in /var/log/vmware/applmgmt/vami.log ?

              • 4. Re: Cant login to Appliance Management
                Niclas_nrk Lurker

                Any hint on which one of the log files I should look in :-)

                • 5. Re: Cant login to Appliance Management
                  bewe Expert

                  the logfile mentioned in my last reply ;-)

                  • 6. Re: Cant login to Appliance Management
                    Niclas_nrk Lurker

                    This is what I get in the vami.log when I try to login:

                     

                    tail -f vami.log

                    2020-03-27T16:25:24.087 [30692]DEBUG:root:Child process still alive, terminating it

                    2020-03-27T16:25:24.087 [30692]DEBUG:root:Process pid=30704, exitcode=0

                    2020-03-27T16:25:24.087 [30692]DEBUG:root:Before pPipe close

                    2020-03-27T16:25:24.087 [30692]DEBUG:root:After pPipe close

                    2020-03-27T16:25:24.087 [30692]DEBUG:root:Before cPipe close

                    2020-03-27T16:25:24.087 [30692]DEBUG:root:After cPipe close

                    2020-03-27T16:25:24.087 [30692]INFO:root:flow is: ['firstboot']

                    2020-03-27T16:25:24.087 [30692]INFO:root:firstboot: succeeded, 100, Starting VMware Performance Charts...

                    2020-03-27T16:25:24.087 [30692]INFO:root:Response :

                    <response><locale>en-US</locale><requestid>getStatus</requestid><value actions="enabled" id="status">succeeded</value><value actions="enabled" id="progress">100</value><value actions="enabled" id="details" /></response>

                    2020-03-27T16:27:24.087 [31499]INFO:root:Processing request

                    2020-03-27T16:27:24.087 [31499]INFO:root:requestid=authenticate

                    2020-03-27T16:27:24.087 [31499]ERROR:session_management:Session Available check failed: No JSON object could be decoded

                    Traceback (most recent call last):

                      File "/opt/vmware/share/htdocs/vami/backend/session_management.py", line 117, in sessionsAvailable

                        cls.expiredSession(ConfigManager(f))):

                      File "/usr/lib/applmgmt/base/py/vmware/vherd/base/config_manager.py", line 25, in __init__

                        object_hook=lambda d: defaultdict(ConfigManager.defaultFactory, d))

                      File "/usr/lib/python2.7/json/__init__.py", line 291, in load

                        **kw)

                      File "/usr/lib/python2.7/json/__init__.py", line 352, in loads

                        return cls(encoding=encoding, **kw).decode(s)

                      File "/usr/lib/python2.7/json/decoder.py", line 364, in decode

                        obj, end = self.raw_decode(s, idx=_w(s, 0).end())

                      File "/usr/lib/python2.7/json/decoder.py", line 382, in raw_decode

                        raise ValueError("No JSON object could be decoded")

                    ValueError: No JSON object could be decoded

                    2020-03-27T16:27:24.087 [31499]ERROR:root:Structure('LocalizableMessage', dict(defaultMessage='The maximum number of sessions has been reached', args=[], id='com.vmware.applmgmt.admind.authenticate.max.session'))

                    2020-03-27T16:27:24.087 [31501]INFO:root:id=getStatus, action=query

                    2020-03-27T16:27:25.087 [22170]INFO:twisted:"127.0.0.1" - - [27/Mar/2020:15:27:25 +0000] "POST /api HTTP/1.1" 200 2783 "-" "vAPI http client"

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:method = com.vmware.appliance.recovery.restore.job.get, args = ()

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:Before PintProcessWrapper call

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:After PintProcessWrapper call

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:After execute call

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:Before getResult Method

                    2020-03-27T16:27:26.087 [31568]DEBUG:root:At pintFunction before importing  Method = 'get', args = ()

                    2020-03-27T16:27:26.087 [31568]DEBUG:root:At pintFunction after importing  Method = 'get', args = ()

                    2020-03-27T16:27:26.087 [31568]DEBUG:root:Beofre exec invoke_method Method = 'get', args = ()

                    2020-03-27T16:27:26.087 [31568]DEBUG:root:Method = 'get', args = [<vmware.appliance.backup_restore.impl.RestoreJob object at 0x7fd156245750>]

                    2020-03-27T16:27:26.087 [31568]ERROR:root:Method failure = <twisted.python.failure.Failure vmware.vherd.base.pint.Error: pint.Error('com.vmware.applmgmt.err_status_does_not_exist', "Status for '%(0)s' does not exist.", **{'args': 'RESTORE'})>

                    2020-03-27T16:27:26.087 [31568]DEBUG:root:Method result = {'attributes': {'args': 'RESTORE'}, 'message': "Status for '%(0)s' does not exist.", 'code': 'com.vmware.applmgmt.err_status_does_not_exist', '__error__': True}

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:At getResult after pipe recv

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:After getResult call

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:Child process still alive, terminating it

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:Process pid=31568, exitcode=0

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:Before pPipe close

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:After pPipe close

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:Before cPipe close

                    2020-03-27T16:27:26.087 [31501]DEBUG:root:After cPipe close

                    2020-03-27T16:27:26.087 [31501]INFO:root:flow is: ['firstboot']

                    2020-03-27T16:27:26.087 [31501]INFO:root:firstboot: succeeded, 100, Starting VMware Performance Charts...

                    2020-03-27T16:27:26.087 [31501]INFO:root:Response :

                    <response><locale>en-US</locale><requestid>getStatus</requestid><value actions="enabled" id="status">succeeded</value><value actions="enabled" id="progress">100</value><value actions="enabled" id="details" /></response>

                    • 7. Re: Cant login to Appliance Management
                      Niclas_nrk Lurker

                      I have solved it by doing this

                       

                      remove files under /var/vmware/applmgmt/sessions folder

                      • 8. Re: Cant login to Appliance Management
                        bewe Expert

                        looks like problems with the session files:

                         

                        please try ssh into vcsa

                         

                        cd /var/vmware/applmgmt

                        mv session/ session.bak/
                        mkdir session

                         

                        then try to login