3 Replies Latest reply on Sep 15, 2020 9:59 AM by HellenButterlips

    "Resource Deadlock Avoided"  - A cautionary tale...

    HellenButterlips Lurker

      For years I've been running my Boot Camp VM from a bootable external Hard Drive on my MacBook. This allows me to quickly jump into windows for small things, but retains the ability to boot into Windows directly for work that requires dedicated HW resources. I recently decided to upgrade from a 500GB SSD to a 1TB SSD. After cloning the drive and verifying that I was able to boot from it directly, VMware was unable to create a new Boot Camp VM. I tried to recreate the VMDK using the rawdiskcreator command in Terminal, but it failed repeatedly with the dreaded "Resource Deadlock Avoided" error. I spent days working with VMware support through email but stumbled upon the root cause and pseudo-solution after hours of troubleshooting myself - Fusion relies on the Vendor and Model names to identify the disk target in the VMDK. Since I have two Samsung T5 SSDs connected (one for Bootcamp; one for Time Machine), it can't discern between them. I've suggested to tech support that they move to something a bit more unique (like the serial number) and hope that message makes its way to the dev team. For now, the workaround is to just unplug my TimeMachine drive when I need to boot up the VM. Hopefully this helps anyone else with a soft spot for brand loyalty (I love the T5 drives) and a heterogenous-OS lifestyle.

        • 1. Re: "Resource Deadlock Avoided"  - A cautionary tale...
          digitalbob55 Lurker

          Hi

           

          I just wanted to say thank you for your post.

           

          I spent a few hours this morning trying to attach two HDDs to a VM using the raw disk creator to no avail - I kept getting the resource deadlock avoided.

           

          Your post instantly made me realise the issue - the two drives are the same make, model, size and even manufactured date!

           

          Unplugged one, job done. I agree that the serial number could be used to differentiate.

          • 2. Re: "Resource Deadlock Avoided"  - A cautionary tale...
            andydvsn Lurker

            Wow. Just wow.

             

            I've been trying to do exactly the same thing on my Mac Pro. I have multiple drives of exactly the same make and model installed and have always received the "Unable to create the source raw disk: Resource deadlock avoided (720905)." error using vmware-rawdiskCreator. It's been having me run around in circles, until I tried creating a .vmdk of a USB device on my laptop, then copied that to the Mac Pro and edited it to match the details of the device I'm actually aiming for. Great, I successfully moved the error from the command line to the main application.

             

            So I tried vmware-rawdiskCreator on the USB device attached to my Mac Pro and to my surprise, it worked. I'd assumed it was machine-specific in some way. So I got searching again and bumped into this post. Upon finding this out I removed all identical drives, leaving only the Windows drive of that type, and tried again. It actually worked. Obviously, completely useless, because I need the other drives attached - but stunning that a piece of software should rely on such a shonky method of identifying drives. Honestly, even I have written better code than that.

             

            Putting one of the drives back in brings the error back, so it's completely replicable. Almost unbelievable, but thank you for finally helping me get to the bottom of this mystery.

            • 3. Re: "Resource Deadlock Avoided"  - A cautionary tale...
              HellenButterlips Lurker

              BUMP  - Just upgraded to v12.0 and confirmed that this issue persists.  VM Ware is still pointing to device names. The struggle continues...