3 Replies Latest reply on Mar 27, 2020 9:54 AM by pgregory71

    VMWare Fusion 11.5.x Mouse Pointer / Text Cursor Lag

    aykay123 Novice

      For months I've been experiencing heavy mouse cursor lags with VMWare Fusion in all Windows applications when the cursor changes to text cursor (caret). It behaves precise in pointer style, but totally starts lagging on text input (e.g. Notepad, see VMWare Fusion 11.5.x Mouse Pointer / Text Cursor Lag - YouTube ). This makes it virtually impossible to e.g. select text.

       

      The issue still exists on macOS Catalina 10.15.4 and VMWare Fusion 11.5.3, even with a clean Windows install and up-to-date VMWare tools. I'm using an external 4K screen (High DPI) and I get the feeling this is making the problem worse. Is anyone else experiencing those issues?

       

        • 1. Re: VMWare Fusion 11.5.x Mouse Pointer / Text Cursor Lag
          edemicco Lurker

          I have the exact same issue.  It occurred in Windows 10 under Fusion 10.x as well. Curiously, I remember seeing a similar issue when I tried Parallels.

           

          I'm also using an external 4K screen with a 2015 MacBook Pro with Intel Iris Pro running 10.14.6. I do not have "Use full resolution for retina display" selected, which seems to make it worse. All displays are running "Default for display" 2x resolution.

           

          It's somewhat better when only using the laptop's panel or in clamshell mode with just the 4K monitor, and using an external monitor at 2560x1440 (not hi-dpi) does not exhibit the issue. The interesting thing is technically the Windows desktop is using less pixels on the 4K monitor (1920x1080 vs. 2560x1440).

           

          I filed a ticket with VMWare support and did spend some time screensharing with them. The conclusion was they would bring it up with engineering and it may get fixed in a future release.

          • 2. Re: VMWare Fusion 11.5.x Mouse Pointer / Text Cursor Lag
            aykay123 Novice

            Thank you for your reply! I am using a MacBook Pro 2018, 2,7 GHz Quad-Core Intel Core i7, Intel Iris Plus Graphics 655 1536 MB.

             

            I've enabled "Use full resolution for retina display" and if I only use the MacBook display I don't experience this problem that much either.

             

            So a few months ago I switched to Parallels Desktop and I can report that there are no problems whatsoever. I somehow still find the Fusion interface cleaner than in Parallels and would therefore like to continue using Fusion, but currently it's not possible.

             

            First there were the performance problems that made VMs with more than a few GB of RAM practically unusable, now the mouse pointer glitch, I am kinda disappointed with the development of Fusion (considering that the previous bug was actually Apple's fault, but Parallels had none of these issues at any time). I hope that VMWare will soon dedicate more passion and resources to the further development of Fusion.

            • 3. Re: VMWare Fusion 11.5.x Mouse Pointer / Text Cursor Lag
              pgregory71 Lurker

              I have the same issue, and here's a workaround that is working for me

               

              Seems whenever VMWare fusion has to re-draw the cursor to something beyond the basic default cursor (arrow) then it slows down or fails.

               

              So, just change your text cursor to the default arrow using these instructions and this worked like a charm for me.

               

              https://www.businessinsider.com/how-to-change-the-cursor-on-windows-10

               

               

              Hope it helps everyone until they can fix the issue!

               

              Phil.