3 Replies Latest reply on Mar 24, 2020 3:58 PM by RobBenedit

    No sound out/ input with VMare Audio Tap devices on physical View Agents

    blazilla Enthusiast
    vExpert

      Dear all,

       

      I'm facing an interesting audio problem with Horizon View on physical agents. Due to COVID-19 we deployed Horizon View at different customers, partially on physical desktops. When using the VMware Virtual Audio (devTap) and VMware Virtual Microphone devices für audio out- and input, the user has not sound in- and output at his desktop. When selecting the correct devices, the user has sound in- and output on the physical desktop, but poor quality when using the same desktop using Horizon View. My guess: When using other devices than the VMware devices, RTAV is not used.

       

      Any hints on how to deal with this? Changing the devices remote is not possible because the user only sees a "Remote Audio Device".

      Best regards
      Patrick

      https://www.vcloudnine.de
        • 2. Re: No sound out/ input with VMare Audio Tap devices on physical View Agents
          blazilla Enthusiast
          vExpert

          Thank you for this hint. Unfortunately this does not fit to my problem. :/

          Best regards
          Patrick

          https://www.vcloudnine.de
          • 3. Re: No sound out/ input with VMare Audio Tap devices on physical View Agents
            RobBenedit Novice

            I ran into a similar scenario last week over our 7.5.2 environment using external direct connections to physical machines. At the end, i could run a webcam, mic with audio through my Horizon direct connection beautifully using a 3-arm external UAG setup.

             

            How I got it to work.

             

            Physical on-prem workstations:

            Uninstalled the Horizon agent - reboot

            Installed the latest Horizon agent 7.12.0, pointed to the first connection broker FQDN, current user ->install options Core, USB redir, Real Time Audio-Video (RTAV) and VMware Audio - reboot

            Logon - Test your speakers and mic first- adjust volumes

             

            Connection Broker:

            Create a new test manual pool

            Add machine and add user

            Setup option for Blast or RDP or PCoIP (worked with any protocol)

             

            Home user machine:

            MIC/Sound issues?  Windows device manager -view-> show hidden devices->uninstall all the Audio input/output and Sound devices then reboot

            It will re-add the needed sound devices

            Use latest full client horizon client from VMware

             

            Observations:

            RDP kept same sessions local or remote, blast did not. Blast logged off your current session and closed all of your applications.

            Lots of options to tweak under the physical gpedit.msc ->Computer-Administrative Templates - VMware Blast (etc)

            Installed the local Horizon admx on the physical workstations to gain Horizon options to enable "Screen blanking" to prevent anyone viewing my RDP onsite.

             

            Give that a run.

             

            r