8 Replies Latest reply on Jun 7, 2020 1:13 PM by TaoeDude

    Windows (7 & 2012R2) corrupting hard drive data when they're a VM on ESXi 6.7.0, but not on bare metal

    TaoeDude Novice

      ESXi version: 6.7.0 Update 2 (Build 13006603)
      Motherboard: SuperMicro X10SRH-CF BIOS v 3.2 (latest)
      OS VMs - WIndows 7 Ultimate and 2012R2, with all mandatory updates installed
      Hard drives: 1TB SanDIsk SSD for ESXi attached to motherboard SATA, and various 6TB data drives

       

      I've only just started experimenting with using VMs and so far I like it.

       

      But last week I was copying very large files (90GB or larger) between a USB3.1 hard drive and a WD SATA 6TB drive attached to the motherboard's controller on a Windows 7 VM, and discovered that the WD 6TB was corrupting the data (and NTFS' various file structures, according to chkdsk). I assumed it was a problem with the drive (though there were no indications in the SMART data that there was a problem) and swapped it out.

       

      The new drive started having the same problems so I decided it must be a cable or controller issue. Swapping cables made no difference so I tried mounting the drive via an LSI SAS controller and SATA breakout cable. No problems. OK, so it appeared to be an issue with the motherboard's SATA controller. I installed SuperMicro's latest chipset drivers and plugged the drive back into the SATA controller but that made no difference. The same problems were exhibited under a Win 2012R2 VM, too. I tried sfc /scannow on both VMs, as well as chkdsk on the system drives, but they no found no issues.

       

      I upgraded the motherboard's BIOS but that made no difference. On a hunch I swapped the ESXi boot drive for a Windows 2012R2 drive so I could run that on the bare metal and... no problems with the drive using the motherboard SATA controller. I copied terabytes of data around over the course of a couple of days and no issues whatsoever. When I replugged in the ESXi and booted that, I immediately started having the corruption and NTFS directory structure problems again.

       

      So I am obliged to conclude the problem is with ESXi.

       

      Does ESXi have the equivalent of sfc /scannow so I can check the integrity of the installation? Is there a way to re-install its chipset/SATA drivers? Any other ideas about what might be going on?