5 Replies Latest reply on Feb 27, 2020 2:35 AM by Ray_handels

    App Volumes JavaScript error

    foo99 Lurker

      Wondering if anyone has come across JavaScript errors with App Volumes?  We have one user of around 150 receiving the attached error at sign in.  If we disable the writable the error does not appear.  We are running an older version (2.12) but have been running for a couple years and this is the first instance of a JavaScript error that we are aware of.

        • 1. Re: App Volumes JavaScript error
          sjesse Master
          User ModeratorsvExpert

          Its not appvolumes throwing the error directly, its an app thats installed in the writeablle that uses the electron framework https://www.electronjs.org/  based on the information in the error. I personlly have fought against having our users use writeables for this reason, if removing the writable fixes it, there aren't really any ways to fix a bad writeable other than deleting it and provisioning a new one. Your on 2.12 I suggest updating as it not supported, and if its a repeated issue open a ticket, but with an outdated version I doubt you'll get far with support.

          • 2. Re: App Volumes JavaScript error
            foo99 Lurker

            Thanks sjesse.  That is what I assumed.  We use the writable for persistence in our environment but are looking really hard at moving to FSLogix as App V has been a trouble spot for us in the past.  That's also why we are still at 2.12.  I had hope for App V 4 but from what we've seen so far it's been a disappointment for us.

            • 3. Re: App Volumes JavaScript error
              foo99 Lurker

              Thanks sjesse.  That is what I assumed.  We use the writable for persistence in our environment but are looking really hard at moving to FSLogix as App V has been a trouble spot for us in the past.  That's also why we are still at 2.12.  I had hope for App V 4 but from what we've seen so far it's been a disappointment for us.

              • 4. Re: App Volumes JavaScript error
                sjesse Master
                vExpertUser Moderators

                I really suggest not abbreviating App Volumes to App V because there is appv( Getting Started with App-V (Windows 10) - Windows Application Management | Microsoft Docs ) which is another app delivery software.

                 

                We held out on 2.12 for a bit, but the upgrade for 2.18 helped alot of our issues, the key thing that would help in the case of writeables is the ability to schedule backups in the manager. 4 is key features we use, which are planned but not yet implemented so I'm waiting.

                1 person found this helpful
                • 5. Re: App Volumes JavaScript error
                  Ray_handels Master
                  vExpertCommunity Warriors

                  Yes, we also had an issue with java applications on 4.0. Not using writable volumes, application is SPSS and an SR has been raised with support.

                  I thought it was an issue with 8.3 naming convention but could well be an issue with Java applications.

                   

                  Looking at the 2.x version. I'd highly suggest (as sjesse also stated) to upgrade to 2.18. 2.12 wasn't the best of all versions. 2.18 seems to be pretty stable. Appvolumes 4.0 also seems to be pretty decent and stable performance and packaging wise, just this java/8.3 naming thing that doesn;t work. Hopefully they will fix it rather quickly..

                  1 person found this helpful