3 Replies Latest reply on Feb 18, 2020 12:50 PM by xian_

    vRA8 Azure cloud account storage exception

    xian_ Hot Shot

      I added an Azure cloud account in Cloud Assembly following Configure Microsoft Azure for use with vRealize Automation Cloud Assembly

       

      It shows regions and storage accounts, can access flavors and images, but Compute resources has not Azure entries.

      The account reports a warning and shows data collection error:

       

      java.lang.IllegalStateException: Azure enumeration adapter '/provisioning/azure/storage-enumeration-adapter-v2' for '/resources/endpoints/eeeeeeeeeeeeeeeeeeeeee': FAILED with com.microsoft.azure.storage.StorageException:
      at com.microsoft.azure.storage.StorageException.translateException(StorageException.java:87)at com.microsoft.azure.storage.core.ExecutionEngine.executeWithRetry(ExecutionEngine.java:209)at com.microsoft.azure.storage.blob.CloudBlobClient.listContainersWithPrefixSegmented(CloudBlobClient.java:346)at com.microsoft.azure.storage.blob.CloudBlobClient.listContainersSegmented(CloudBlobClient.java:259)at com.vmware.photon.controller.model.adapters.azure.enumeration.AzureStorageEnumerationAdapterServiceV2.lambda$getStorageContainersAndDisks$28(AzureStorageEnumerationAdapterServiceV2.java:914)

       

      What is missing here? I can't find any logs either...

        • 1. Re: vRA8 Azure cloud account storage exception
          stevedrummond Hot Shot

          There are a number of issues with Azure cloud accounts in vRA 8. I currently have a bunch of critical SR's open with engineering though no fix has been provided at this stage.

           

          Unfortunately it has made Azure completely unusable for us at this time.

           

          I don't know that I've seen that particular error though. Is your Azure account least privilege? Have you tried just given it Owner/Contributor rights just to make sure it isn't a permissions issue?

           

          Have you tried tailing the provisioning-service log while it's performing a data collection? It sounds like the snippet you've provided is just what the UI shows?

          • 2. Re: vRA8 Azure cloud account storage exception
            xian_ Hot Shot

            Privileges should be sufficient, Owner and Contributor roles assigned as in the referenced doc.

             

            I checked the provisioning service logs and I saw SSL errors, more than likely caused by our SSL proxy I Need to get those fixed first, I believe.

             

            Thanks for the suggestion, I'll report on the progress.

            • 3. Re: vRA8 Azure cloud account storage exception
              xian_ Hot Shot

              The problem was our internal proxy replacing certificates with its own.