1 2 3 Previous Next 32 Replies Latest reply on Mar 2, 2020 6:07 AM by chengtmskcc Go to original post
      • 30. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
        ChristophBaecker Novice

        I opened a ticket with one of my customers (OnPrem 19.07.0.19) an we came to a solution and it was nothing that was mentioned in this thread (the patch 19.07.0.15 comes closest or to be precise, what it actually does, but did not work in my case!), so either there are many different reasons for the issue to occur, or some posts are out of context or simply wrong/misunderstandings or there are just many solutions, this one included.


        However, starting with 1907 the way the tunnel/Api access is working changed and somehow might be broken afterwards if it was configured in earlier releases. Check the following on all CS/DS/API-Servers:


        Open ' filepath.txt'  in ' C: or AirWatch or AirWatch 1907 or Supplemental Software or Tools or UpdateSQLServerInfo'  (or ' AirWatch %version%'  you are running in the custom path you chose) with Notepad++ and search for ' AirWatch.ApiGateway'


        If you find that, you can most likely ignore this post. If not, that's most likely one reason for the issue. Next Search for ' AirWatch.DevicesGateway'  and below that line, add:


        .. or .. or .. or Websites or AirWatch.APIGateway or Web.config


        Safe the file filepath.txt. Then start ' UpdateSQLServerInformation.exe'  located in the same folder as admin and click ' Update' . This puts the previous change into the associated config files associated with DB-Access.


        Now - according to support - a restart of that server/all servers where you did the change) is recommended. If that`s not possible, restarting the following services might do it:


        AirWatch API Workflow
        AirWatch Tunnel Service


        ____________________________________


        As always: No Backups, little sympathy. Feeling safer Contacting VMware Support or Partner? Of course, do so!


        However, if this has helped you (or not), I would love to know including the version you are running. Thank you!


        _____________________________________

        @Olaf

        As you are running UAG 3.7, just in case no edge services and HA come alive after a reboot one day, you are facing the follwoing issue:

        https://kb.vmware.com/s/article/76424

        Ignore this, if you already fixed this. ;-)

        1 person found this helpful
        • 31. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
          jahuu Novice
          Thanks Christoph.
          I also open a case an today I become same solution - and it works. In my case the ' line'  Airwatch.APIGateway or Web.config'  was present in the filepath.txt - the Support just Change ' API'  to ' Api' , save the file - updatesqlserverinformation.exe - restart services an I can open the Tunnel Configuration Page now..
          2 people found this helpful
          • 32. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
            ChristophBaecker Novice
            Interesting and disturbing.

            On my fresh 1909 working Test-Installation ' API'  it is indeed written in Capital letters. In the customers environment 1907 it was added ' Api'  by support.

            I will keep an eye on that, thanks for pointing that out Olaf!
            • 33. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
              syarbrou Enthusiast

              So do we know what the official reason for this is and the solution?  Here's our situation.  We have been running on 19.7.0.18 for a while now.  Basically the day the .18 patch came out we have been on it whenever that was.  VPN has been working fine.  Couple days ago we noticed a yellow triangle next to the VPN Profile on one of our test devices but ignored it since it wasn't the reason for our testing and just thought it was because the Tunnel app wasn't also assigned to the device.  So we just setup one of our company presidents new phones and boom his per app VPN won't work and he's annoyed.  Now none of the devices will install.  So this wasn't necessarily part of an upgrade, happened a while later so find this a bit odd.  Also I can not access on the OG that is configured, the Tunnel config in All Settings.  I've been off for a couple days but don't think my team has figured it out yet.

               

              Thanks.

               

              Steve

              • 34. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                Vestengen Novice

                19.07.29 patch or upgrade to 19.09 should fix it. Or create a ticket to get help adding the missing api record in the database

                • 35. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                  syarbrou Enthusiast

                  Thanks, I'll try applying the latest patch Monday and see what happens.  Do we have any idea why it would just work and then suddenly stop?  Makes no sense.  Looked like most people found it when they updated but mine was working for months before it starting having this enrollment problem.

                   

                  Thanks.

                   

                  Steve

                  • 36. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                    Vestengen Novice

                    I have no idea, but got the same problem. Worked for months, then suddenly stopped. Support fixed it manually by creating the missing database record.

                    • 37. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                      syarbrou Enthusiast

                      Errrr.  Well I hope it works.  That said, I'm going to be a conspiracy theorist and say that it's because they are trying to get everyone to move to the cloud version and these kinds of problems are their way of making you do it.  Not the first time something popped up and we all had to react to it to get a fast fix.

                      • 38. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                        syarbrou Enthusiast

                        By the way updating now.  Also does this happen with versions of 19.09 as well?  Think my dev environment is on 19.09.04 and one of my team said it has the same problem.

                         

                        EDIT:  Updated the database, device server, and console server.  We are going to test enrollment but the tunnel page still errors for us.  We are on 19.7.0.39.

                         

                        EDIT EDIT:  Thought I posted an update but guess not.  The update didn't help.  Enrolling a device still won't accept the tunnel profile.

                        • 39. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                          JoeBeaty Novice

                          I contacted support about this because all of the sudden my tunnel profile stopped working.  What they said was this was related to an API string in the appsetting.json file where the DB password is not getting update by the tunnel service after a 90 day period.  This is why they said we didn't see it right away.

                           

                          They sent me an updated UpdateSQLServerInformation.exe file which had the same hash as my current file.  Here were the instructions to fix:

                           

                          1. Download the zip (you will need to get this from support)
                          2. copy to UpdateSQLServerInformation.exe to E:\AirWatch\AirWatch 1907\Supplemental Software\Tools\UpdateSQLServerInfo\ (replacing E: with the installed drive and "AirWatch 1907" with your current version)
                          3. Run the UpdateSQLServerInformation.exe on the API server (this is our DS server)
                          4. Restart services.

                           

                          Oddly enough after a screen share session, it just started working again without running UpdateSQLServerInformation.exe.

                           

                          Hope this helps.

                          • 40. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                            syarbrou Enthusiast

                            Thanks for the steps.  We have a ticket open but think it's still pending.  Based on your findings I am curious if updating to 1909 will even help at this point.

                             

                            EDIT:  We spoke with VMware.  They said there are a number of issues and different fixes going around right now for VPN Profile problems so said they would take our errors and find the best fix for our situation.  So guess we wait.  Showed them some of what was in the forum but they wouldn't commit yet to a solve which I guess makes sense as there are numerous fixes in this thread alone for what seem like similar problems.

                            • 41. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                              JeromeFRAUD Lurker

                              jahuu

                               

                              Hi,

                               

                              Same issue, same solution like you.

                              Thanks !!!!!

                               

                              I was in 19.9.0.12.

                              • 42. Re: cannot open tunnel configuration page after upgrade 1907 patch 5
                                chengtmskcc Expert

                                I didn't realize this issue happened way back in August of 2019. In any case, it's 'finally' fixed in console version 2001.

                                 

                                “An error has occurred” when browsing to GROUPS & SETTINGS > Configurations > Tunnel in VMware Workspace ONE UEM – Thoma…

                                1 2 3 Previous Next