1 2 Previous Next 15 Replies Latest reply on Apr 3, 2020 5:10 AM by AndreasDoerfler

    Workspace ONE Notebook

    MHaagSoehner Enthusiast

      Hey guys,


      does anyone have any experience with the Workspace ONE Notebook app?


      I've deployed it recentely but can't get the Exchange integration to work, invalid credentials. I have an open support case already since I know that the credentials are correct but wanted to know if anyone uses the app already.


      Regards, Max

        • 1. Re: Workspace ONE Notebook
          Novice
          Hello Maximilian,

          Yes, I did a test two weeks ago.
          But I did not get it run from external (I mean with the external Address of our EWS service on Exchange).
          I always got the same error message that you get. (By the way, the error message makes no sense at all because I am sure there was a connection problem).

          I tried it internal with our internal EWS URL and it worked without problems ( We dont even had the Basic authentication enabled on exchange).
          I will but my head in this topic again in the next weeks, maybe we can help each other.

          BR
          Michael
          • 2. Re: Workspace ONE Notebook
            LukeDC Expert
            If you are on office 365 and are using modern auth then you’ll have issues. They don’t support modern auth yet apparently.
            • 3. Re: Workspace ONE Notebook
              MHaagSoehner Enthusiast
              Hey Michael,
              Hey Luke,

              thanks for your replies!

              We're still using an on-premise Exchange 2010 but will be upgrading to on-prem 2016 in a month or so.

              Our Exchange server is only reachable through the SEG V2. I configured an app VPN for the notebook app because of that. I can open the EWS URI in Safari on iPhones through VMware Tunnel and in the corporate Wi-Fi.

              I've tried the interal + external URI and the IP address of our exchange server already.

              For you Michael, do we need to enable the Basic authentication?


              Hope you guys have a great day!

              Max
              • 4. Re: Workspace ONE Notebook
                TMoellerkommunit Lurker
                Hi Maximillian,

                I just tried to config the Notebook App as well and also got not connection to the Exchange.
                The connection should be used via the SEGv2 but as the config in the App automatically fills the line with a path directed to the Exchange and not the Gateway I think.
                So the connection should point directly to the Exchange. I tried to connect the App with VPN to the internal network but it looks like the App needs an internet connection?!?

                Do you got some information from your support call and can you share it with me?

                Hope to hear from you!
                BR
                Tobias
                • 5. Re: Workspace ONE Notebook
                  MHaagSoehner Enthusiast
                  Hey Tobias,

                  sorry for the late reply! We've been trying to fix that issue ever since with the help of the VMware Support but haven't been able to do so.

                  We're going to upgrade from Exchange 2010 to Exchange 2016 anyway this month so we're not going to troubleshoot the problem further. I have a feeling that the issue is not on VMware's side since I know a few customers that have the EWS connection up and running. I'll update y'all if it works with our upgraded Exchange 16 or not.

                  Cheers!
                  Max
                  • 6. Re: Workspace ONE Notebook
                    Novice
                    Looks like it possible to publish EWS endpoint on SEGv2 for ENSv2 support https://docs.vmware.com/en/VMware-Workspace-ONE-UEM/1903/WS1-Secure-Email-Gateway/GUID-AWT-SEGV2-ENS-SUPPORT.html , but looks like this endpoint does not work for Notebook.

                    Currently using VMWare Tunnel - Proxy to connect internal EWS endpoint, but it does not look like elegant solution for me.
                    • 7. Re: Workspace ONE Notebook
                      SebastianSchmutzler Lurker
                      Hi all,

                      I've the same issue like max (can't login).
                      I've configured the app as descried in the manual (SDK Profile). The settings will be populated in the App.
                      The problem exists from external (connection via App Tunnel) and from the internal wifi. I've checkt the connectivity from AppTunnel and wifi to our Exchange servers (can Access OWA).
                      The Basic Authentication isn't enabled for EWS on our exchange (2016) servers. --> NTLM is officically supported by VMware.

                      Does anybody has an Idea how to resolve the issue?
                      • 8. Re: Workspace ONE Notebook
                        MHaagSoehner Enthusiast
                        Hey Boris,
                        Hey Sebastian,

                        yeah, I've been thinking about VMware Tunnel aswell, the VPN is pretty stable on mobile so I wouldn't mind. I'm currently in the process of migrating to Exchange 16 and expect that to be done by next week. I'll let you all know if it works then!



                        • 9. Re: Workspace ONE Notebook
                          MHaagSoehner Enthusiast
                          Hey guys,

                          so, we've finished our Exchange 2016 upgraded and WSONE Notebook works great now. The only differences between the old system and the new one that I can see are:

                          1. Exchange 2016 instead of 2010
                          2. We're using a hostname instead of an IP-adress to connect to EWS
                          3. We have a valid certificate for Exchange 2016

                          We're still using VMware Tunnel to connect to our EWS. I feel like the certificate was the trigger here, if you're using an IP-address in your app configuration, try changing it a hostname and, if possible, try to get an official certificate.


                          Regards,
                          Max
                          • 10. Re: Workspace ONE Notebook
                            ArianZuta Novice
                            Hi All,

                            Any news on that? I do also get the issue that the credentials are not working. However, the exchange being used is Exchange 2016.
                            Best Arian
                            • 11. Re: Workspace ONE Notebook
                              MHaagSoehner Enthusiast

                              Hey Arian,


                              it worked for me as soon as I upgraded from Exchange 2010 to Exchange 2016. Make sure that your EWS URL is properly configured in EAC.


                              You can check your current config in powershell: Get-WebServicesVirtualDirectory |Select name, *url* | fl


                               


                              My Workspace ONE Notebook App configuration looks like this:
                              exchangeURL = https://mail.domain.com/EWS/Exchange.asmx
                              userEmail = {EmailAddress}
                              userName = domain or {EmailUserName}


                              I'm also using per app VPN for the Notebook app. Our EWS allows Windows and anonymous authentication in IIS.


                              Are you using a self-signed cert for your Exchange?


                              Hope this helps,


                              Max

                              • 12. Re: Workspace ONE Notebook
                                ArianZuta Novice
                                Hi Max

                                Thanks for your reply.
                                The EWS Url is publicly available. Is it really required to establish a perAppVPN Session for the Notebook app?
                                The certificate used is signed by a trusted CA.

                                Best Arian
                                • 13. Re: Workspace ONE Notebook
                                  MHaagSoehner Enthusiast
                                  I doubt it's required, I just use a VPN because our Exchange is not publicly available
                                  • 14. Re: Workspace ONE Notebook
                                    jwkrock Novice

                                    Is there no way to route the Notebook app through the SEG?

                                     

                                    It seems kind of silly that Boxer goes through the SEG, but this app doesn't.  A little short-sighted, no?

                                     

                                    The entire point of the SEG is to act as a proxy between your network and EWS, so why would an app from VMWare not include this functionality out of the box?

                                    1 2 Previous Next