2 Replies Latest reply on Jan 17, 2020 10:26 AM by scott28tt

    Can't unmount datastore. Datastore is busy vsandevicemonitord

    anthonyaudi Lurker

      Hello,

       

      I'm trying to unmount an iSCSi datastore. It's a second datastore I have along with a vsan datastore. I want to remove it but I cannot. I configured the scratch logs to go to that datastore but as far as I can tell the vsandevicemonitorlogd.log is in use and I can't seem to delete it. I tried to unmount the datastore / delete it / I cannot do anything.

      Can anyone tell me how I could get rid of the datastore cleanly. I can probably go in the iSCSi console and just delete it but then vmware would see it as a dead datastore.

      The only thing I initially configured was the scratch logs [] /stracth/log but I have since removed that, I tried to reboot one of the hosts also and still cannot remove the file

      Is there a service that I can possibly stop so I can remove this open file? Also, I see that it is vsandevicemonitord.log that is running, it this a critical file to my vSAN environment? If I stop it will my vSAN stop working? I know it's not recommended but can I put the scratch logs on the production vSAN datastore? <-- I believe that is not recommended correct?

      Ideally, I wanted to put the scratch logs on my NFS store but every time I try I get a path not found error.

       

       

      Thanks!