10 Replies Latest reply on Jan 3, 2020 2:25 AM by a.p.

    Team ESXi 6.5 NICs with HPE 1820 and 1910 switches....

    ikt Enthusiast



      I'm struggling to get NIC teaming (aggregating) between a ESXi 6.5 host and HPE switches.


      Here are my VSwitch settings (interfaces inherit their settings from vswitch)


      Link discovery, mode: Listen

      Link discovery, protocol: Cisco discovery protocol


      Security, Promiscuous mode: Reject

      Security, MAC address changes: Reject

      Security, Forged transmits: Reject


      NIC teaming, Load balancing: Route based on IP hash

      NIC teaming, Network failover detection: Link status only

      NIC teaming, Notify switches: Yes

      NIC teaming, Failback: Yes

      NIC teaming, Failover order:

        vmnic4 - 1000Mbps - Active

        vmnic5 - 1000Mbps - Active

        vmnic6 - 1000Mbps - Active

        vmnic7 - 1000Mbps - Active


      Traffic shaping: Disabled.


      I think my vmware settings are more or less correct, or what?


      However I need to know more about how to set up the HP switches, if LACP is used or not etc...


      First HP switch: HPE 1920S-24G - JL381A

      Menu item: Trunks / Configuration

      Have configured three trunks with 4 ports each.  All with a bunch of tagged VLANs.


      Here are the default trunk settings:


      Admin mode: Enabled


      STP Mode: Disabled


      Static Mode: Enabled (should it be dynamic to allow LACP?)


      Load balance (5 choices, what do I select here??):

      Source MAC, VLAN, Ethertype, Incoming port

      Destination MAC, VLAN, Ethertype, Incoming port

      Source+Destination MAC, VLAN, Ethertype, Incoming port

      Source IP and Source TCP-UDP Port fields

      Destination IP and Destination TCP-UDP Port fields

      Source+Destination IP and Source+Destination TCP-UDP Port fields


      Second switch:  HPE V1910-24G

      Menu item: Network / Link aggregation

      Have configured three trunks with 4 ports each.  All with a bunch of tagged VLANs.


      The default setting for each trunk is:

      Aggregation interface type: Static

      (should I enable LACP for the ports here?)


      If I should use LACP, it has its own menu item where I can select which switch ports to enable for LACP and the priority between the system and the LACP ports.


      Menu item: VLAN / Modify Port:

      Selected all trunks and changed all their ports 'Link type' from 'Access' to 'Trunk' type port.


      I have played a lot with this and ended up with no traffic flow at all or only traffic via one of the interfaces...  

      Thanks a lot for comments on which settings are correct or if I need to do something else...