5 Replies Latest reply on Dec 17, 2019 4:45 PM by continuum

    Invalid operation increasing disk dize

    myoungcpr Lurker

      VM version 13
      build 5310538

      ESXI: 6.5
      Edge Ver. 44.18362.449.0 / Chrome 79.0.3945.79


      Thick provisioned, lazily zeroed disk that was restored form a Datto appliance .VMDK export, then cloned from a NFS share mounted as a datastore, to a datastore on the host using vmkfstools -i (per Datto knowledgebase.) Once moved a new Vm was built on the restored disks. The C:\ drive has given no trouble, but the D:\ seems to be throwing a fit.
      We are having issues with the back up of this Vm, and they are requesting that the disk reporting be in Gb rather than Tb. However, as soon as I open the 'edit settings' option for the Vm, it is already complaining about putting in a larger size for the disk.

      Regardless of the size that is put in, I get an "unable to reconfigure VM: invalid operation on device 3" error. Even if I put in 1025 Gb for the size rather than the 1.0000276858918369 Tb it currently shows, the disk share option still shows red unless I cycle it from one option to another.
      I've removed any snapshots and consolidated, but no luck.
      We have another Vm that was restored in the same way that does not have this issue when attempting to reconfigure.disk.PNG


      I'm at a bit of a loss as to why this Vm seems to want to cause problems.

        • 1. Re: Invalid operation increasing disk dize
          a.p. Guru
          Community WarriorsUser ModeratorsvExpert

          Welcome to the Community,


          you are running an old ESXi build, in which the Embedded Host Client still had severeal issues. To rule out such issues, please close the client, delete the browser cache, and then check whether things changed.

          If you still get the same error, then please attach the VM's .vmx file as well as the virtual disk's .vmdk descriptor file (the small text file) to your next reply. You may download the descriptor file using a tool like WinSCP.



          • 2. Re: Invalid operation increasing disk dize
            pragg12 Hot Shot

            Do make a cold copy on the VM before attempting any operations. I would recommend doing this on another datastore to avoid confusion.


            Use incognito mode of the web browser of your choice. Once you have a cold clone of the VM, try increasing size. If it gives error, un-register the VM. Then register the VM. And try increasing the size again.

            • 3. Re: Invalid operation increasing disk dize
              myoungcpr Lurker

              Attached are the files, unfortunately there was no change after clearing the browsers. Would it be worth trying to update the host client to the most current available?


              I'm unable at the moment to cold clod the Vm but will tonight after production hours.

              • 4. Re: Invalid operation increasing disk dize
                a.p. Guru
                vExpertUser ModeratorsCommunity Warriors

                How exactly did you convert the virtual disk, i.e. which exact "vmkfstools -i ..." did you use?

                According to the metadata, it seems that the disk has originally been created as an IDE virtual disk (IDE disks cannot be increased), which has been modified later.


                • 5. Re: Invalid operation increasing disk dize
                  continuum Guru
                  vExpertCommunity Warriors

                  I am not surprised at all that you cant expand this vmdk via the UI.

                  At the moment change block tracking is active while it is declared as very old virtual hardware.

                  It uses the optional

                  ddb.adapterType = "lsilogic"

                  which contradicts the IDE-geometry

                  ddb.geometry.cylinders = "2130500"

                  ddb.geometry.heads = "16"

                  ddb.geometry.sectors = "63"

                  The size of the flat.vmdk is not alligned to full MBs

                  which may be another reason why the UI cant expand it:

                  RW 2147543103 VMFS "DCROWN-flat.vmdk"

                  size in MBs = 1048605.030761719

                  To expand this vmdk stop the active backup job and delete all ctk.vmdks.

                  Then remove ctk-entries from the vmx and use this vmdk descriptor:

                  # Disk DescriptorFile







                  # Extent description

                  RW 2147543040 VMFS "DCROWN-flat.vmdk"


                  # The Disk Data Base


                  ddb.adapterType = "lsilogic"

                  ddb.geometry.cylinders = "133678"

                  ddb.geometry.heads = "255"

                  ddb.geometry.sectors = "63"

                  ddb.virtualHWVersion = "8"


                  If I had to expand this vmdk I would use dd and write a new descriptor.