1 Reply Latest reply on Dec 4, 2019 4:40 PM by behealed

    VMWare Player 15 can't map virtual drive to host...

    behealed Lurker

      In VMWare Player 15, the button to map the virtual drive to the host is greyed out, with no explanation or tooltip when I hover the cursor over it.

       

      And if I go to explorer, and browse to the virtual disk file, and right click it, and select "Map Drive", it gives an error: "Error reading volume information. Please select another disk file."

       

      Both my host and my VM are running windows 10 pro. The VM machine is powered off, and no other VM's are running. But if I boot up the VM, and right click on drive C and select "Properties", it says that the virtual drive is formatted as NTFS. I also right-clicked the virtual disk file, and confirmed that it says nothing about it being compressed, and permissions for all accounts include read and write and full control. As for encrypted, I'm not even sure what that is, but I do not know of any reason why the disk would be encrypted.

       

      Looking around on Google, I found this page: Map or Mount a Virtual Disk to a Drive on the Host System

       

      Which says that NTFS is supported, and to power off the virtual machine. So it should be working? Why is it giving me this error? Is there a bug in VMWare Player 15?

       

      I see other people have been reporting this same problem (the button greyed out) for years, with nobody ever giving an answer to explain why. Please someone, it's a deal breaker for me to be unable to access the virtual machine's files while the virtual machine is powered off.

       

      UPDATE: I can literally right click the *.vmdk file and click 7z->Open Archive to open it in 7-zip, and it not only opens it, but lets me browse around through the whole drive. How in the world is 7-zip able to do this, and not VMWare? My opinion of VMWare as a company is literally going downhill, if they are being out-programmed by 7-zip. But back to reality, I can't really use the 7-zip solution because I need to be able to edit and modify the files, including windows system files (files that you can't edit while windows is running), which I assume will only be possible if I can mount the drive. If anyone knows a way where I can individually edit files on the virtual disk while the virtual machine is powered off, please, let me know I'm desperate and been searching for hours.

        • 1. Re: VMWare Player 15 can't map virtual drive to host...
          behealed Lurker

          Update: I installed Iimdisk toolkit, which appears to be free, and then i could right click the virtual disk file and mount it super easy with no fuss. Haven't tried yet to modify files but it looks like it is working. It looks like there's quite a few tools you can find online to mount VMDK files, that all work infinitely better than the VMWare Diskmount Utility (which appears to no longer be working, and no longer being updated). So in case I never come back to this post ever again, just assume that it's because imdisk toolkit worked for me.