10 Replies Latest reply on Dec 15, 2019 1:20 PM by swilmann

    vRops 8 admin account

    swilmann Lurker

      After upgrading to vrops 8

      I have to keep resting the admin account password to logon.

      using

      $VMWARE_PYTHON_BIN $VCOPS_BASE/../vmware-vcopssuite/utilities/sliceConfiguration/bin/vcopsSetAdminPassword.py --reset

       

       

      after one logon with the account any new attempts fail with incorrect logon.

       

      has anyone else seen this? 

        • 1. Re: vRops 8 admin account
          chdrei Novice

          Hello,

          have a look at this KB:

          VMware Knowledge Base

          if it applies, you should also take a look at the

          log files, to see what is causing the false logins.

           

          In our case, we can see following:

          2096680e-81b8-4356-bb8b-63ec80c672d4, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

          in the logfile:

          /storage/vcops/log/analytics.audit-XXXX.log

          this started with the update from 7.5 to 8.0.

          Well, we'll have to open a SR.

           

          cheers

          Chris

          1 person found this helpful
          • 2. Re: vRops 8 admin account
            RickVerstegen Expert
            vExpert

            Log on to the admin UI after reset and change the password again. Try again to logon.

            I recommend to enter the password recovery settings to ensure that in case you lose your admin password, you can use the recovery email to recover the password. (Administrator settings).

            When saved, on admin login screen, you will notice an option of "Forgot Password". If you lost your password you can use this option and you will receive an email with a reset password link,

            • 3. Re: vRops 8 admin account
              chdrei Novice

              Hello Rick,

              that's a workaround, not a solution.

              We are seeing the same issue.

               

              regards

              Chris

              • 4. Re: vRops 8 admin account
                sxnxr Expert
                vExpert

                I have had a case for this with vmware for over a month now and they are still no closer to finding the problem. In my case i dednt even get to do the upgrade. as soon as i changed the password with in 10 mins it was locked out.

                 

                It will lock out every 10 mins. We have now external systems using this account and no adapters either but every 10 mins it locked out. If i get anywhere with support i will let you know.

                1 person found this helpful
                • 5. Re: vRops 8 admin account
                  chdrei Novice

                  We've got a solution for our problem, the vRealize Life Cycle Manager was still

                  using the old password. I've just changed it and will wait and see, what happens.

                   

                  The vMware Support identified, from where the login requests were coming from.

                   

                  regards

                  Christopher

                  • 6. Re: vRops 8 admin account
                    bnagabhushan Novice
                    VMware Employees

                    Correct, after you reset the password. Immediately login to your vROPS UI and check if there are any other adapters where you would have used the admin account for configuration or if there are any other solutions like login sight where you would have integrated your vROPS and update the new password there.

                    • 7. Re: vRops 8 admin account
                      sxnxr Expert
                      vExpert

                      Mine locks out every 10 mins and i have nothing using the admin account and the logs dont have a source just that it is being locked out

                      • 8. Re: vRops 8 admin account
                        swilmann Lurker

                        Got a call open with VMware now.

                        FYI

                        there are no adaptors using the admin account.

                        also found out I cant get any domain accounts to connect (the ones passed through from VC) keep getting the error User does not have any roles assigned.

                        also no Lifecycle manager installed at this place so not that.

                        tried reset through the admin portal no luck.

                        have created an local adminbackup account so i can get in via that. so i got that going for me.

                         

                        hope they can help or vrops is unusable

                        • 9. Re: vRops 8 admin account
                          chaohanyu Lurker

                          I've had similar issue with both vROPs (from 7.5 to 8.0) and vRLI (from 4.8 to 8.0), although the issue occurred with upgrade via LCM 8.0

                          • admin login gets locked out
                          • root still works as well as all the users configured via IDM
                          • same as your situation it takes $VMWARE_PYTHON_BIN $VCOPS_BASE/../vmware-vcopssuite/utilities/sliceConfiguration/bin/vcopsSetAdminPassword.py --reset to fix the problem

                           

                          Sincere regards

                          Chao

                          • 10. Re: vRops 8 admin account
                            swilmann Lurker

                            used this to User Activity Audit  to check logons

                             

                            log is filled with this. pretty much every 5 mins.

                             

                            2019-12-15 08:18:35,089 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:23:39,149 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:28:43,211 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:33:45,266 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:38:49,319 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:43:54,381 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:48:55,439 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                            2019-12-15 08:53:59,491 - UserId : aa0a17e4-7c0e-4311-804e-24187fe09ef8, UserName : admin, AuthSource : LOCAL, Session : n/a, Category : LOGIN - Log in failed

                             

                            VMware are saying it is vRLI but we dont have it installed.