0 Replies Latest reply on Nov 28, 2019 10:46 PM by phillipfromoz

    VMWare perl SDK - What packages are required in addition to main package

    phillipfromoz Lurker

      Hi,

      I'm try to run list_vms.pl using perl sdk vmware.

       

      So I installed:

      VMware-vSphere-Perl-SDK-6.7.0-8156551.x86_64.tar.gz

       

      However the perl sdk vmware does not appear to install:

      Com::Vmware::Vapi::Util::Logger

      which is required by the perl script, list_vms.pl

       

      Question

      Is this by design or did I do something wrong during the install?

      If not, what other perl VMWare SDK packages do I need?

       

      ps. perl is not very helpful as the main SDK requires lots of modules

      and even using cpanm [cpanminus] there were many packages that I need that

      needs to be done by hand. This is not an VMWare problem but more of a perl

      problem.