4 Replies Latest reply on Nov 29, 2019 6:48 AM by toku565

    ESXi 6.7 U3 で物理NICがリンクダウンしたままになる

    toku565 Lurker

      こんにちは。

      ESXi6.7U3(Build 14320388)でIntel X540-T2(2Port,10Gbps)を装着しています。

      ドライバは問題なく認識し、Port1のみ利用していました。

      Port2も同様に利用しようとしてCat5eケーブルを装着後確認するとリンクアップが1Gbpsとなっていました。

      vSphere Web ClientよりPort2のみオートネゴシエーションを無効にし、全二重10000Mbpsにしたところ、

      2ポート目のみリンクダウンとなり復旧できなくなりました。

       

      ESXi再起動、ケーブル交換、Port1のケーブルも抜線するも復旧せず。

      CLIより

       

      esxcli network nic up -n vmnic3

       

      を試したところエラーなく実行されました。

      (nic down)も同様です。

      ですがリンクダウンのままとなります。

       

      esxcfg-nics -lで見たところでは

       

      vmnic2  0000:01:00.0 ixgben      Up   1000Mbps   Full   12:34:56:78:90:1a 9000   Intel Corporation Ethernet Controller 10 Gigabit X540-AT2

      vmnic3  0000:01:00.1 ixgben      Down 0Mbps      Half   12:34:56:78:90:1b 1500   Intel Corporation Ethernet Controller 10 Gigabit X540-AT2

       

      というような結果となります。

       

      ハード故障として交換するのは最終手段ですが他に調査すべき項目があればアドバイスをいただけないでしょうか?

      よろしくお願い致します。

        • 1. Re: ESXi 6.7 U3 で物理NICがリンクダウンしたままになる
          gowatana Master
          User ModeratorsvExpert

          こんにちは。

           

          NICのモデル、ESXiバージョン、ドライバ(ixgben)を

          VMware Compatibility Guide で確認すると、タイプに「Partner Async」も含まれていました。

          念のため、利用されているサーバ ベンダの推奨しているドライバが利用できているか確認しておくとよいと思います。

          (たとえば、ベンダのカスタム イメージの ESXi があるならそれを利用しているか、推奨されるNICドライバのVIBをインストールしたか、など)

          https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=20396

           

          あと、10Gbpsのリンクで利用する想定のようですのでケーブルはCAT6のほうがよいかもしれません。

           

          以上です。参考になるかどうか・・・

          1 person found this helpful
          • 2. Re: ESXi 6.7 U3 で物理NICがリンクダウンしたままになる
            kawaman Expert
            vExpertVMware Employees

            ちょうど最近 DellEMC のコミュニティでも X540-T2 での質問があって調べ物してたので共有します。

            まず、gowatana さんが記載されたように 10G BASE-T は Cat5e は非サポートとなり、リンクアップしても 1GbE での認識や、撚りが悪いケーブルなどではリンクアップすらしないので、まずは Cat6、出来れば Cat6a のケーブルで試してください。

             

            手元で確認が出来た PowerEdge R630 の 10G Base-T モデルでは、DellEMC がリリースしているカスタムISOイメージ(zip depot)を利用して最近 6.7u3 に更新しましたが、

            Cat6a を利用していれば以下の様に正常認識されます。

            Capt_20191122_002.png

             

            適用されているデバイスドライバの詳細は esxcli で確認できますので「ixgben」にどのVIBが適用されているか、確認してみて下さい。

             

            [ :~]  esxcli hardware pci list

            0000:01:00.0

               Address: 0000:01:00.0

               Segment: 0x0000

               Bus: 0x01

               Slot: 0x00

               Function: 0x0

               VMkernel Name: vmnic0

               Vendor Name: Intel Corporation

               Device Name: Ethernet Controller 10 Gigabit X540-AT2

               Configured Owner: VMkernel

               Current Owner: VMkernel

               Vendor ID: 0x8086

               Device ID: 0x1528

               SubVendor ID: 0x1028

               SubDevice ID: 0x1f61

               Device Class: 0x0200

               Device Class Name: Ethernet controller

               Programming Interface: 0x00

               Revision ID: 0x03

               Interrupt Line: 0x0f

               IRQ: 255

               Interrupt Vector: 0x00

               PCI Pin: 0x00

               Spawned Bus: 0x00

               Flags: 0x3201

               Module ID: 21

               Module Name: ixgben

               Chassis: 0

               Physical Slot: 4294967295

               Slot Description: NIC1

               Passthru Capable: true

               Parent Device: PCI 0:0:3:0

               Dependent Device: PCI 0:1:0:0

               Reset Method: Function reset

               FPT Sharable: true

             

            [ :~] esxcli software vib get

             

            INT_bootbank_ixgben_1.7.10-1OEM.670.0.0.8169922

               Name: ixgben

               Version: 1.7.10-1OEM.670.0.0.8169922

               Type: bootbank

               Vendor: INT

               Acceptance Level: VMwareCertified

               Summary: Network driver for Intel(R) 10 Gigabit NIC

               Description: Native ixgben network driver for VMware ESXi

               ReferenceURLs:

               Creation Date: 2018-09-06

               Depends: vmkapi_2_5_0_0

               Conflicts:

               Replaces:

               Provides:

               Maintenance Mode Required: True

               Hardware Platforms Required:

               Live Install Allowed: False

               Live Remove Allowed: False

               Stateless Ready: True

               Overlay: False

               Tags: PCIID 808610f7, PCIID 808610f8, PCIID 808610f9, PCIID 808610fb, PCIID 808610fc, PCIID 80861507, PCIID 80861514, PCIID 80861515, PCIID 80861517, PCIID 8086151c, PCIID 80861528, PCIID 8086154d, PCIID 80861557, PCIID 80861558, PCIID 80861560, PCIID 80861563, PCIID 80861565, PCIID 808615aa, PCIID 808615ab, PCIID 808615ac, PCIID 808615ad, PCIID 808615ae, PCIID 808615c2, PCIID 808615c3, PCIID 808615c4, PCIID 808615c6, PCIID 808615c7, PCIID 808615c8, PCIID 808615ce, PCIID 808615d1, PCIID 808615e4, PCIID 808615e5, module, driver

               Payloads: ixgben

            ご参考まで、、、

            1 person found this helpful
            • 3. Re: ESXi 6.7 U3 で物理NICがリンクダウンしたままになる
              toku565 Lurker

              ご返信ありがとうございます!

               

              Cat6Aにしても駄目でした。

              ドライバ自体は対応しているものでした。

              最初はNIC交換になるかと…。

              • 4. Re: ESXi 6.7 U3 で物理NICがリンクダウンしたままになる
                toku565 Lurker

                ご回答ありがとうございます!

                 

                Cat6Aを試しても駄目で、私の場合はFUJITSU TX1310M1でしたので、

                富士通カスタムISOイメージよりOS入れ直すことでNICが認識されました。

                https://my.vmware.com/jp/group/vmware/details?downloadGroup=OEM-ESXI67-FUJITSU&productId=742

                ただし、WebClientから何故かアクセスできなかったりするのですがそれはまた別の話。

                 

                一旦クローズします。

                お二人に感謝します。