12 Replies Latest reply on Dec 2, 2019 5:36 PM by AhmedIbrahimVMware

    Installing our own SSL certificate

    HayleyGRIT Lurker

      Hi all,

       

      I seem to be going round in circles trying to upload a SSL certificate to ESXi 6.7.0. We are not managing this through and vCenter server, its a standalone VM which will be host to a Cisco 9800 CL device.

       

      So far we have a SSL certificate in use by ESXi which has been generated by ESXi.

       

      Issuer

      O=VMware Installer

      Not valid after

      Tuesday, May 27, 2031, 18:16:46 +0100

      Not valid before

      Tuesday, November 26, 2019, 17:16:46 +0000

      Subject

      unstructuredName=1574788605\,564d7761726520496e632e,CN=smyserver.mycompany.local,emailAddress=ssl-certificates@vmware.com,OU=VMware ESX Server Default Certificate,O=VMware\, Inc,L=Palo Alto,ST=California,C=US

       

      Whenever I browse to the webGUI of this device I am getting a security alert which is to be expected as I have not installed the above certificate but my aim is to use our local STAR.mycompany.local certificate on the ESXi device as this is what we use on all of our servers around the company. The certificate is then pushed out across our domain so no id

       

      So, I have tried to replace the SSL cert with our company certificate but it just gives errors and reverts back to the original one. I have tried to follow several guides also and 9 times out of 10 I am losing all access to the device and I have to reinstall. I am using a PEM file but maybe it has to be converted somehow?

      Can anyone give me any tips on how I can get this to work?