1 2 Previous Next 21 Replies Latest reply on Apr 8, 2020 11:39 AM by sschramm

    Fusion Pro 11.5.1 mousepointer bug

    protoolzer Lurker

      Been running OSX High Sierra vm for a few years but the 11.5.1 update gives a mousepointer (graphical) bug where the normal sized mousepointer is behind a expanded bigger one.

        • 1. Re: Fusion Pro 11.5.1 mousepointer bug
          Nils Dacke Novice

          I believe I have the same problem with 11.5.1.

          The hot spot of the visible mouse pointer is not at the pointer tip, but a few pixels down and to the right. So to select something I have to point over and to the left of the control I want to click.

          My VM host is a MacBook Pro 2014, latest Mojave 10.14.6 and the VM guests I have tried are Mojave 10.14.6 and Catalina 10.15.1.

           

          For now I reinstalled Fusion 10.15.0, which does not have this bug. Don't know if Windows guests have the same mouse problem. Any solutions or workarounds, please?

          1 person found this helpful
          • 2. Re: Fusion Pro 11.5.1 mousepointer bug
            RickShu Expert
            VMware Employees

            Hi protoolzer,

             

            Would you please post a screenshot and attach it to this thread? Also, have you tried to re-install the VMware Tools in your VM?

             

            Regards,

            -Rick

            • 3. Re: Fusion Pro 11.5.1 mousepointer bug
              RickShu Expert
              VMware Employees

              Hi Nils Dacke,

               

              What kind of mouse are your using in VM? TouchPad, Apple Magic Mouse, or an external USB/Bluetooth mouse?

              Have you tried with the options in VMware Fusion==>Preferences==>General==>Gaming

               

              Regards,

              -Rick

              • 4. Re: Fusion Pro 11.5.1 mousepointer bug
                tkhayes Novice

                I have the same issue.  Windows 10, latest updates 1909+.  Catalina 10.15.1, Fusion 11.5.1.  USB standard Dell mouse plugged into my Mac keyboard USB port.  Mouse pointer is abnormally large and the click point is not where it should be.

                 

                I reinstalled VMWare Tools, no change.  restart no change.  Shutdown and restart Fusion App, no change.  Checked and turned off gaming settings that were mentioned, no difference.

                 

                Screen shot does not seem to capture the mouse pointer, not sure how to do that.  I attached mouse settings from Windows Settings.  The mouse is set to small, but is actually X-large

                Screen Shot 2019-11-20 at 7.05.32 AM.png

                 

                Odd behavior that I did notice.  Open an explorer window.  Move mouse to corner to resize window.  The mouse indicator changes to the 'resize' arrows but is above and to the left of where it should be.  When I click the left mouse button, the arrows resize to normal and appear where they should be - on the corner of the window.  Release the mouse button and the resize arrows again enlarge and move out of position.

                 

                Can send a screenshot if I can find a way to do that, the mouse pointer never seems to save during a screenshot.  Here's from my iphone - I position the mouse to resize a window.  Pointer changes but is huge and out of position

                IMG_6263.jpeg

                Now when I click and hold the left mouse button, the pointer changes to normal size and normal position

                IMG_6264.jpeg

                1 person found this helpful
                • 5. Re: Fusion Pro 11.5.1 mousepointer bug
                  protoolzer Lurker

                  Hi tkhayes.

                   

                  Your screenshots is EXACTLY what i experience..... if i move the mose fast then (because of normal console lagging) i will see the real size mousepointer behind the 4-5x sized one.

                   

                  I never did anything with mouse settings in my vm and have been running this osx (10.13.6) for as long as i can remember now (al most since high sierra came out).

                  This is a bug that definitely came out with the 11.5.1 update because i never seen this before :-(

                   

                  My mouse settings allways said "mac profile" in the vm (if that is the question.

                  mouse_bug.png

                   

                  Thats how it looks when i move mouspointer fast (that i see "multiple" mouspointers is normal because of latency, but as you see the pointer that follows the big one is the REAL one.

                   

                  Regards

                  Thomas

                  • 6. Re: Fusion Pro 11.5.1 mousepointer bug
                    protoolzer Lurker

                    Hi

                     

                    Please see my other post.

                     

                    I did reinstall vmware tools as the first step to try fix, but no change.

                    Settings for the VM never changed as it has been working fine for all updates since i first created the osx high sierra install

                     

                    Regards

                    Thomas

                    • 7. Re: Fusion Pro 11.5.1 mousepointer bug
                      kwaltman Novice

                      I have the same issue on one of Dev VM's running Win 8.1 Ultimate under Fusion 11.5.1. My mouse pointer was offset compared to where I clicked. It was even worse when I opened up Remote Desktop Connector and connected to one of the machines at work from it. Nearly 32 pixels offset.

                       

                      I finally rolled my Fusion back to 11.5.0 and the problems went away. So if you can roll back, try that and see if that fixes the issue. For sure something in the 11.5.1 screwed the pouch on this, and I have been going mental trying to figure out what it was since mid last week.

                       

                      11.5.0 DL link.

                       

                      https://my.vmware.com/group/vmware/details?productId=798&downloadGroup=FUS-1150

                      2 people found this helpful
                      • 8. Re: Fusion Pro 11.5.1 mousepointer bug
                        protoolzer Lurker

                        Yes, I did the same to right now. Finally everything feels normal again.

                        I really hope Vmware will fix this in the next update.

                         

                        11.5.0 is good.

                         

                        Thomas.

                        • 9. Re: Fusion Pro 11.5.1 mousepointer bug
                          protoolzer Lurker

                          RickShu

                           

                          I tried checking that preferences (basically tried to change to all available options one by one, but no luck.

                          Personally i use my XX years old Microsoft habu mouse (still fantastic!!!!). Vmware is running on high sierra here (latest built). Never had a problem until 11.5.1.

                           

                          Thanks

                          Thomas

                          • 10. Re: Fusion Pro 11.5.1 mousepointer bug
                            jjsp357 Lurker

                            Thank you so much for this. I had a similar problem documented here, which was driving me crazy. I uninstalled 11.5.1, installed 11.5.0, and all is well again.

                            • 11. Re: Fusion Pro 11.5.1 mousepointer bug
                              DiGaEF Lurker

                              I have the same issue.

                              since Fusion 11.5.1

                               

                              - Ubuntu 18 problem with mouse focus

                              - Linux Mint problem with mouse focus

                               

                              - Windows 10 1909 no problem

                               

                              Hope VMware will fix it soon. I dont want to downgrade ...

                              • 12. Re: Fusion Pro 11.5.1 mousepointer bug
                                sudorun Lurker

                                I have the same issue with 11.5.1.  11.5.0 was fine.

                                 

                                I can work around the issue with this:

                                Re: mouse pointer is offset up and to the left about 1/4 inch

                                VMWare Fusion -> Preferences -> General.  For "Gaming:" select the option "Always optimize the mouse for games".

                                 

                                But this is inconvenient as CTRL-CMD is then required to move the mouse out of the VM window to other Mac apps.

                                 

                                ---

                                 

                                Update: I downgraded to 11.5.0 which doesn't exhibit this issue.  Definitely a 11.5.1 issue.  Hopefully it will be fixed in 11.5.2...

                                • 13. Re: Fusion Pro 11.5.1 mousepointer bug
                                  EdSteinman Lurker

                                  I have had the same problem since installing 11.5.1. Have tried changing VM resolution in VM settings and screen resolution in Windows Control Panels. The resolution does change but the cursor offset does not. Have used Fusion for years and never had this problem before. In addition to the cursor offset part of the main window is inactive--the cursor cannot be moved into the right 3% or so of the screen.

                                   

                                  One thing that *does* work to fix all of the above problems: turn on pointer trails in the Windows Mouse Control Panel. One downside: you can't click on Mac OS Notifications while on the Windows side.

                                   

                                  Macbook Pro, Catalina, Windows XP

                                  • 14. Re: Fusion Pro 11.5.1 mousepointer bug
                                    CharlieHeaps Lurker

                                    I have exact same bug on 11.51.  Also doing the workaround requiring the gaming mouse settings, but this is a real PITA.  This is very basic functionality.  Come on VMWARE! What is the status of a fix for this?  Its many months now since 11.5.1 was released.

                                    1 2 Previous Next