5 Replies Latest reply on Nov 19, 2019 7:48 AM by Seekso

    [vRA 8.0] Error using ABX extensibility

    Seekso Lurker

      Hello the community.

       

      I'm currently trying to use the new ABX functionality in vRA 8.0 to do a simple thing, rename the VM before the provisioning.

       

      First of all I create a new action based on the embedded script (I tried both Python and JS versions of the script)

       

      Then I create a new subscription based on the topic compute.allocation.pre (which I guess is the right topic to rename a resource)

       

      Finally I ask for a test blueprint to be provisioned. I can see that the ABX action is called in the "Action Runs".

       

      But the blueprint systematically failed with the error : "Extensibility triggered task failure: Extensibility error for topic compute.allocation.pre: [10040] Image creation KJob is NOT completed!"

       

      Does anyone succeed to deploy a VM customizing the name ?

      Maybe I'm using the wrong way, but there is a serious lack of documentation about extensibility capacities, which if for me one of the most important part of vRA.

       

      Thanks for your help !

        • 1. Re: [vRA 8.0] Error using ABX extensibility
          itrudeau Novice

          Hello Seekso.

           

          You will not have to relaying on ABX for custom name of you resource machine.

           

          you can simply use a custom naming template in you project and use input in you blueprint.

           

          Here how you can doying this.

           

          In cloud assembly.

          Go to Infrastructure --> Projects

          Select your Project.

          click the Provisioning tab.

          scroll down to section "Custom Naming (Beta).

          Input in the template field : ${resource.name}

           

          on your blueprint simply create a input:

           

          EX:

           

          inputs:

            hostname:

              type: string

              default: none

          resources:

            vSphere_Machine:

              type: Cloud.vSphere.Machine

              properties:

                name: '${input.hostname}'

           

          This will rename the vm with the input hostname.

           

          I hope this help out.

           

          Regards.

          • 2. Re: [vRA 8.0] Error using ABX extensibility
            kumar6384 Enthusiast

            Hi,

             

            Add the "customProperties" before your input parameters.

             

             

            Thanks.

            • 3. Re: [vRA 8.0] Error using ABX extensibility
              stevedrummond Enthusiast

              Your job is failing because the container for on-prem ABX extensibility has not been installed; it does not come with the appliances.

               

              I am assuming you are behind a Proxy otherwise it would have worked. You will need to follow the KB (VMware Knowledge Base) to configure your proxy.

               

              You will need to whitelist gcr.io, docker.io and storage.googleapis.com on your Proxy.

               

              Also note that you will not be able to pull dependencies through the Proxy until at least 8.0.1 as it is not currently supported.

              • 4. Re: [vRA 8.0] Error using ABX extensibility
                Seekso Lurker

                Hello. It's a good idea, however I'm currently trying to use some more complicated use cases through the extensibility, and the most simple test is to rename the resource

                But I keep that in my mind.

                • 5. Re: [vRA 8.0] Error using ABX extensibility
                  Seekso Lurker

                  Hello. Thank for your answer. However this can't resolve my issue as even with a constant string ("MYVMNAME") in the script the rename action can't be executed. I think there is something I misunderstood with the output of ABX actions...