0 Replies Latest reply on Nov 8, 2019 4:11 PM by sadponyguerillaboy

    Black Screen when Booting Apple EFI Diagnostics in EFI Shell

    sadponyguerillaboy Lurker

      When booting apple efi based diagnostics from an efi shell, it hangs on a black screen.

      Vmware Fusion:

      - hdd 1 = macos 10.13 high sierra

      - hdd 2 = formated ms-dos fat from disk utility on hdd 1

      - copy over apple efi based diagnostics to hdd 2

      - copy over efi boot loader boot64.efi to Root/EFI/ of hdd 2

      - set hdd 2 as startup disk

      - boot hdd 2 which starts efi shell

      - navigate to .diagnostics folder in efi shell and run start diagnostics utility

      - hangs on black screen

       

      I have set my *.vmx file to reflect host (board-id, serial, etc.) and have also tried entering components manually. But am still unable to set boot rom or smc version.

       

       

      It hangs just before loading the gui. I can tell from the diagnostic log files that it hangs just before loading the gui image.

       

      Has anyone else tried to emulate this same procedure?