1 Reply Latest reply on Nov 10, 2019 8:14 AM by MohAzizKandil

    Getting Service unavailable Error while deploying multilanguage OVA

    dips_b Lurker

      I am working on multilanguage of OVF and followed below documents for same.

      https://blogs.vmware.com/vapp/2009/09/ovf-localization.html

      https://www.dmtf.org/sites/default/files/standards/documents/DSP0243_1.0.0.pdf

       

      I am able to generate ova successfully but am getting an error(PFA screenshots Error in chinese, Error in english) while deploying the ova.

       

      I created two message files and one ovf descriptor which looks as shown below

      Content of MyVM-en-US.msg file

      <Strings xmlns:ovf="http://schemas.dmtf.org/ovf/envelope/1" xmlns="http://schemas.dmtf.org/ovf/envelope/1" xml:lang="en_US">

          <Msg ovf:msgid="Product.label">Product in English </Msg>

      </Strings>

       

      Content of MyVM-zh-CN.msg file

      <Strings xml:lang="zh-CN">

          <Msg ovf:msgid="Product.label">▒▒▒ Product in Chinese</Msg>

      </Strings>

       

      OVF descriptor:

      <Envelope xml:lang="en-US" xmlns="http://schemas.dmtf.org/ovf/envelope/1" xmlns:cim="http://schemas.dmtf.org/wbem/wscim/1/common" xmlns:ovf="http://schemas.dmtf.org/ovf/envelope/1" xmlns:rasd="http://schemas.dmtf.org/wbem/wscim/1/cim-schema/2/CIM_ResourceAllocationSettingData" xmlns:vmw="http://www.vmware.com/schema/ovf" xmlns:vssd="http://schemas.dmtf.org/wbem/wscim/1/cim-schema/2/CIM_VirtualSystemSettingData" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

          <References>

      <File ovf:href="MyVM-zh-CN.msg" ovf:id="msgs1"/>

      <File ovf:href="MyVM-en-US.msg" ovf:id="msgs3"/>

          </References>

      <VirtualSystem>

      <AnnotationSection ovf:required="false">

                  <Info>A human-readable annotation</Info>

                  <Annotation ovf:msgid="Product.label">OVF NAME: abc

                  </Annotation>

              </AnnotationSection>

          </VirtualSystem>

      <Strings xml:lang="ja_JP" ovf:fileRef="msgs2"/>

      <Strings xml:lang="en_US" ovf:fileRef="msgs3"/>

      </Envelope>

       

      I am getting below error when I deploy the ova

      "Service unavailable. Error getting https://<SERVER-IP>:443/cls/data/5fdc4919-c82b-4d3f-8a34-c13a7c91c86c/abc-file3.msg: HTTP/1.1 503"

      I have uploaded screenshots of error as well as contents of ova.

      Please suggest if I am missing something.