4 Replies Latest reply on Nov 11, 2019 2:10 AM by jonl123

    Unable to copy between datastores

    jonl123 Lurker

      I have 6 ESXi hosts running under vCenter, all using local storage.

       

      On one of the hosts copying files between datastores isn't working - both between datastores on the host and when the copy from or to datastore is on another host.


      However, performing a file upload to the datastores on the host does work. File copies are working fine on all other hosts.

       

       

      When performed within ESXi I get the error "Failed - The operation is not allowed in the current state". From with vCenter the error is "Could not complete network copy for file".

       

      Everything was ok on the host until a week ago. I saw a possible error within the iDRAC on one of the raid arrays, upgraded the firmware on the host (which resulted in a storage driver/firmware mismatch at one point), though I'm not sure if the file copy issue was there before or not. I was able to vMotion everything off the host before the firmware upgrade.

       

      Everything is showing ok within the iDRAC. I ran VOMA against the datastores and it came back ok. There is a 3rd volume on the host which is used for the ESXi install and that appears fine.

       

      I tried deleting one of the datastores and re-creating and the issue is still there.


      Any ideas?

        • 1. Re: Unable to copy between datastores
          Gidrakos Enthusiast

          Are you getting any pertinent errors in the ESXi or vCenter logs?

           

          Is this happening for all VMs, both powered on and powered off?

          • 2. Re: Unable to copy between datastores
            Amin Masoudifard Expert

            can you try copying the file in CLI (SSH or Shell) by running the following command and tell me the result?

            cp /vmfs/volumes/(datastore1)/file  /vmfs/volumes/(datastore2)/file

            Please mark my comment as the Correct Answer if this solution resolved your problem
            • 3. Re: Unable to copy between datastores
              Clifford11 Lurker

              In the client go to Configuration - Storage and right click the datastore and browse. It opens up a window and you can see the various vm folders. In the Right Window right-click the folder and you should see copy. For some reason you don't see it in the left pane login to upsers

              • 4. Re: Unable to copy between datastores
                jonl123 Lurker

                Thanks for the replies. I figured out the issue and it was pretty simple - the host was in maintenance mode, once this was exited all was ok.

                 

                It didn't help that I was looking for problems as we'd just had an issue with the raid controller and drivers/firmware but the strange behaviour didn't help either.

                 

                Sometimes when I performed a copy the destination folder was deleted (I think only when it was empty). Other times there was no response at all in vCenter to the copy.

                 

                Plus the error messages suggest a different issue. The hostd log said about maintenance mode, not sure why the errors in vCenter / ESXi wouldn't say the same?