3 Replies Latest reply on Nov 26, 2019 7:53 AM by seekerofknowledge

    Updated WorkStation 15 Pro and unable to start VM with "Could not open /dev/vmmon: No such file or directory."

    richardfoley Lurker

      I've been running WorkStation 15 Pro for some time now.

      VMware Workstation 15.5.0 build-14665864

      Using several VMs within it. Having received the notification to upgrade from the VMplayer itself I clicked on "ok" (or whatever the text is to continue). The installation proceeded smoothly (installation successful). Then I started the vmplayer and attempted to start a previously working VM, as one does, and received the following error message:

      Could not open /dev/vmmon: No such file or directory.

      Please make sure that the kernel module `vmmon' is loaded.

      This error doesn't mean much to me, in terms of how to fix this. I tried to file a support request (having paid for license), but was unable to get past the complex support interface which denied my request. So I come to the community. I'm using Debian 10:

      $> uname -a
      Linux thpad.localhost 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64 GNU/Linux

      Following on from this, I did manage to locate a description of how to sign the module concerned. The commands I used were:

      openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=VMWare"
      /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon)
      /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmnet)
      mokutil --import MOK.der --root-pw
      shutdown -r now

      I still get the same error as above in the OP. If someone has an idea of how to fix this, I'd appreciate a simple explanation, if this is possible, to correct this unexpected error which has imho. been caused by using the authoritative upgrade process. I'm a developer/end-user of VMs, and I'd rather not have to "just patch the kernel"...

       

      I'd greatly appreciate any helpful advice/instructions which enables my VMs to work again.

       

      Many thanks in advance.

       

      R.

       

      Message was edited by: Richard Foley to include OS and VM WorkStation Pro version info.

       

      Message was edited by: Richard Foley to include the MOK.der signing process used.