1 Reply Latest reply on Dec 9, 2019 7:47 AM by plugstar

    Is Thin App broken on version 5.2.x?

    plugstar Lurker

      OK I've been packaging with Thin App for the past 5 years and never encountered as many errors as I do now


      I am hitting a number of issues with a simple web-app that contains Java 6 update 17, Crystal Reports and a 3rd party ActiveX component. The website is also added to the trusted site zone and the pop-up blocker exception list.

      The shortcut to launch the app is calling the locally installed internet explorer and then the URL of the website.

      The app has previously been packaged on Windows 7 using Thin App 5.1.1 however as we are moving to Windows 10 this application needs to be rebuilt in the later capture tools to resolve crashes on launch.


      So far i have encountered the following issues since either rebuilding or recapturing this application using 5.2.4.

      1. Scripting causes the app to fail to launch.

      Using the same script on 5.1.1 and the app launches fine.
      However on 5.2.4 this doesn't work and the app doesn't open.


      Here is the script.

           Function OnFirstParentStart

                ExecuteVirtualProcess("RegSvr32 /s " & chr(34) & "C:\Windows\Downloaded Program Files\OSSPlugin.dll" & Chr(34))

           End Function
      This script was used as Thin App doesn't seem to be able to capture the registration for this dll.

      A main function of the application won't work without this dll registration.


      2. Internet Explorer 11 has issues with temporary internet files

      Another function of the website i am capturing has documents stored which are opened from with the browser.
      A large number of these files are stored in *.Tiff format due to scanning the documents in. However i get the following error below.

      ThinApp error.png



      For my Windows 7 clients if i revert these users back to Internet Explorer 8 the *.Tiff files open without issue. However this is not possible on Windows 10 and as such i have a lot of unhappy clients


      3. Office 2016 documents are unable to be opened.

      As well as storing documents in *.TIFF format a large number of word and excel documents are also stored on this site.
      Attempting to open Excel documents and the Excel process is spawned but terminates immediately.

      For Word the application opens but again the application is unable to find the documents.

      ThinApp error2.png

      I have added the office processes to ChildProcessEnvironmentExceptions and set the ChildProcessEnvironmentDefault to both External and Virtual. On both occasions this meant that the Java applet wouldn't load, the website was no longer in the trusted site zone (captured in the package) and crystal reports no longer worked. However the office documents would load.


      I can only get the documents to launch successfully with a combination of Internet Explorer 8 and Office 2010 installed.


      Please note i have installed the components manually on windows 7 and 10 and both all works fine.

      I have captured the application on Windows 7 using App-V and the applications works fine on either Windows 7 or 10.


      So due to this i have an app that works as long as I package in 5.1.1, use scripting, have Internet Explorer 8 installed and Office 2010. This basically kills the app for use on Windows 10 as the app won't run if captured using 5.1.1 and we have internet explorer 11 and office 2016 installed.


      Can anyone provide any pearls of wisdom to try and get this application to work?  I have tried over 25 combinations of Merged vs WriteCopy directory isolations, ChildProcessEnvironmentExecptions on or off, VirtualizeExternalOutOfProcess on or off and none of which work.



        • 1. Re: Is Thin App broken on version 5.2.x?
          plugstar Lurker

          I decided to raise a support case with VMware on this issue as the client I work with has a support contract in place.


          The response i got was not what i was expecting.



          Issue with opening Word, Excel, tif files fails on Windows 10.



          Application is in ThinApp bubble and attempts to interact/pass the information with natively installed applications (IE11, Office) - this operation is not supported.



          In order to accomplish this, the natively installed applications would need to be virtualized by ThinApp, so that they would be within the same "bubble"; unfortunately those applications are not supported under Windows 10.


          So based on this i would assume all interactions with internet explorer are not supported?

          We've decided to revert back to installing the components directly onto the OS using SCCM.

          My concerns going forward is that we have a lot of applications that use Internet Explorer and Office and we are getting a number of incidents raised for Windows 10 users complaining of issues and crashing etc.


          Looks like we will be moving away from ThinApp for Windows 10