0 Replies Latest reply on Oct 29, 2019 10:35 AM by glassin

    vm files won't go away

    glassin Novice

      So this is just a mystery at least to me.  I had a vmdk file on local host storage simply disappear one day.  (we rebuilt from scratch).  But the folder remains with some files inside including .vmx & .vmx.lck  In vsphere trying to right click and delete the folder or files results in a generic error.

       

      drop to SSH nav to the datastore and folder.  From folder   rm -rf foldername and i get every file in folder results as   rm cannot remove invalid argument.

       

      if i attempt each individual file i get the same error    rm filename   'invalid argument'.  I have tried rmdir but the directory isn't empty so that is an issue.

      i tried chmod 777 filename just to ensure i have full but i also get 'invalid argument'

       

      vmfstools -B gives me an error of cannot break link.

       

       

      This folder is not important to me but eating up too much space is there anyway to just delete it?   am i doing something incorrectly?

       

      Last note this is the local store that has ESXI OU itself installed so i don't think i can simply format but if i could i would.

       

      thoughts are appreciated.