2 Replies Latest reply on Nov 8, 2019 12:55 AM by C3VM

    vSphereCLI6.7がWindowsServer2012R2にインストールできない

    C3VM Novice

      vSphereCLI6.7をWindowsServer2012R2にインストールしようとしましたが、「このバージョンでは使用できません」のメッセージが表示されてしまい、インストールできません。

      リリースノートには、サポートされているプラットフォーム一覧にはあるのです。

      vSphere Command-Line Interface 6.7 Release Notes

       

      原因などわかりますでしょうか?

      WindowsServer2012R2Datacenterだからでしょうか?

      Standardでなければだめとかありますでしょうか?

        • 1. Re: vSphereCLI6.7がWindowsServer2012R2にインストールできない
          kawaman Expert
          vExpertVMware Employees

          試しに手元にあった、Windows Server 2012 R2 DataCenter Edition と Windows Server 2016 Standard Edition に

          my vmware から現在入手可能な vSphere CLI 6.7 Build 8156551 をインストールしてみましたが、

          インストーラは問題なく動作し、正常にインストールできました。

          ※ perl は事前にインストールされていてもいなくても、vSphere CLI 6.7 のインストーラの挙動には影響ありませんでした。

           

          私の方で試した限りでは原因は分かりませんでしたが、Windows Server 2012 であればインストーラは動くことが確認できたので
          ファイルそのものが壊れているか、OS側で何等かログ、メッセージが残されているか確認するのも切り分けになるかと思います。

          ・ダウンロードした実行ファイルが壊れていないかhash値を確認する

          ・イベントにエラーログなど記録されていないか

          ・可能であれば OS を再起動してみる

           

          ご参考まで

          • 2. Re: vSphereCLI6.7がWindowsServer2012R2にインストールできない
            C3VM Novice

            すみません。

            インストールできました。

            こちらの手順違いでした。

            お手数をおかけしました。