4 Replies Latest reply on Oct 14, 2019 11:46 PM by eborovac

    Move-VM cmdlet with datastore cluster

    eborovac Lurker

      Hi,

       

      I'm attempting cross vCenter migration of VMs using Move-VM PowerCLI cmdlet.

      Migration to a datastore works fine.

      Migration to a datastore cluster fails.

      Is this a known limitation of move-VM cmdlet?

       

      Thanks.

        • 1. Re: Move-VM cmdlet with datastore cluster
          LucD Guru
          Community WarriorsUser ModeratorsvExpert

          Which PowerCLI version are you using?

          The Move-VM cmdlet help states it is supported.

          Are you getting any errors?

          • 2. Re: Move-VM cmdlet with datastore cluster
            eborovac Lurker

            Thanks for the reply Luc.

             

            move-vm : 15/10/19 3:42:41 pm Move-VM When migrating a VM to a different vCenter Server both Destination and Datastore need to be specified. No other destination types but VMHost/Resource Pool and Datastore are supported for Cross vCenter vMotion

             

            PowerCLI Version

            ----------------

               VMware PowerCLI 11.2.0 build 12483598

            ---------------

            Component Versions

            ---------------

               VMware Cis Core PowerCLI Component PowerCLI Component 11.2 build 12483642

               VMware VimAutomation VICore Commands PowerCLI Component PowerCLI Component

            11.2 build 12483638

               VMware VimAutomation Vds Commands PowerCLI Component PowerCLI Component

            11.2 build 12483615

             

            At the moment workaround is the following passed to move-vm datastore option

             

            -datastore (get-datastorecluster -server $dst_vc $datastore_cluster | get-datastore | sort-object -property FreeSpaceMB -descending | select -first 1)

            • 3. Re: Move-VM cmdlet with datastore cluster
              LucD Guru
              User ModeratorsCommunity WarriorsvExpert

              The latest PowerCLI releases (currently 11.4) did include some Move-VM changes.
              It might be worth trying an upgrade.

               

              If that doesn't help, I would still suggest opening an SR.
              At least the help page for Move-VM is incorrect.

              • 4. Re: Move-VM cmdlet with datastore cluster
                eborovac Lurker

                Upgraded but still have the same issue.

                 

                Thanks for suggestions.