8 Replies Latest reply on Oct 11, 2019 11:34 AM by LShields1

    Trouble installing update 15.5.0

    ultimate_live Novice

      Today I tried to install  latest update of VMware Workstation Player but I wasn´table to do it. After starting, I get follwing message:

       

      Captura de Tela (553).png

       

      Ok. Restarted computer and started program again. Same message. and if I click on NO, nothing happens and the installations doesn´t go on.

      How can I fix it?

        • 1. Re: Trouble installing update 15.5.0
          PeteM92 Novice

          This VMware Knowledge Base (kb.vmware.com/kb/55798) article refers to installing Microsoft Visual C++ 2017 Redistributable.

          C++2017 is however already included in Windows 10 version 1903 Build 18362.356 as a part of Microsoft Visual C++ 2015-2019 Redistributable.

          Obviously this is not recognized by the installer routine.

          • 2. Re: Trouble installing update 15.5.0
            PeteM92 Novice

            Meanwhile I found, that this problem only occurs if you try to update an existing installation of VMware Player.

             

            You have to uninstall the existiting previous version, now you can install this latest version without error message.

            Uninstall of previous versions was not necessary up to now.

             

            When you now restart an existing virtuel machine and start updating of VMware Tools, this error message appears in the virtual machine.

            You have to restart the virtual maschine and start updating Tools a second time.

             

            This is also an abnormal behaviour, which I never observed before.

            • 3. Re: Trouble installing update 15.5.0
              MathiasR Enthusiast

              I worked around this error by manually running the 64 bit vcredist installer that was contained in the extracted VMware installation folder in temp.

              • 5. Re: Trouble installing update 15.5.0
                JVScontrols Lurker

                Clicking "repair" when I ran the "VC_redist.x64.exe" installer from the link above and rebooting allowed me to run  latest VMware workstation installer that I downloaded to my hard drive.   I didn't use the update process as prompted when I launched VMworkstion although I don't know if it matters after the Microsoft product as been run and rebooted.

                • 6. Re: Trouble installing update 15.5.0
                  lindros2 Novice

                  This has been a complete nightmare for me.

                  First, VMw WS Pro 14 failed after a Windows update (KB4517211).

                  Then, I paid $149 to upgrade to WS Pro 15, only to have this crap happen.

                  I'm done with VMware. After 20 years, this nonsense is over.

                  • 7. Re: Trouble installing update 15.5.0
                    candidesh Novice

                    I upgraded from WS 12.5.9. Had to uninstall this version first, then install 15.5.0 was successful in 2 minutes. Install process makes no hint that this is necessary is the only hurdle.

                    • 8. Re: Trouble installing update 15.5.0
                      LShields1 Lurker

                      I had the same issue trying to update my Windows 10 Pro 1903 system.  After several reboots and no indication of why install was failing, I found a workaround.  My situation is that I have Visual Studio 2019 on my host.  I actually have both VS 2019 released, and VS 2019 Preview versions installed, so I suspected that I am running a very recent version of MS VC++ Redistributable.

                       

                      So while the 'VMware Product Installation' window with that message is being displayed.  I opened up my 'C:\Users\myaccount\AppData\Local\Temp' folder location in the file explorer, and based on the date time stamp located the temporary VMware installation folder {15FBF7C8-0102-49A3-809B-3A662ADA3396}~setup, as shown in the screenshot below.

                       

                      tempvmwarefolder.png

                       

                      In the folder are three files:

                       

                      vcredist_x64.exe

                      vcredist_x86.exe

                      VMwarePlayer.msi

                       

                      I confirmed my suspension regarding VC++ Redistributable when I attempted to run the installation.  I was able to see the actual failure message from the vcredist_x64.exe installer indicating 'Another version of the product is already installed'.

                      msvcredisfailmessage.png

                       

                      So after closing the MS VC++ 'Setup Failed' window, I proceeded to run the 'VMwarePlayer.msi', and the VMware Player Setup Wizard launched.

                      vmwareplayerinstaller.png

                       

                      This proceeded to install VMware Player 15.5.0 as expected.  Upon completing, I rebooted and the update is working.